Version 7.4

Andren

LoranGPS

By Andren Software Co.
<table>
<thead>
<tr>
<th>Task</th>
<th>Hot Key:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open File</td>
<td>Ctrl-O</td>
</tr>
<tr>
<td>SAVE FILE</td>
<td>Ctrl-S</td>
</tr>
<tr>
<td>SAVE FILE AS</td>
<td></td>
</tr>
<tr>
<td>SAVE AS V5 or V6</td>
<td></td>
</tr>
<tr>
<td>BACKUP/RESTORE FILES</td>
<td></td>
</tr>
<tr>
<td>Delete A File</td>
<td></td>
</tr>
<tr>
<td>Find Missing File</td>
<td></td>
</tr>
<tr>
<td>File Properties</td>
<td></td>
</tr>
<tr>
<td>COMBINE FILES</td>
<td></td>
</tr>
<tr>
<td>SPLIT FILE</td>
<td></td>
</tr>
<tr>
<td>SORT FILE</td>
<td></td>
</tr>
<tr>
<td>Print File</td>
<td>Ctrl-P</td>
</tr>
<tr>
<td>Printing Format</td>
<td></td>
</tr>
<tr>
<td>Last Three Files Opened</td>
<td></td>
</tr>
<tr>
<td>Quit, Close</td>
<td>Ctrl-Q</td>
</tr>
<tr>
<td>Set R/B Reference</td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl-X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl-C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl-V</td>
</tr>
<tr>
<td>Add Waypoints</td>
<td>Ctrl-A</td>
</tr>
<tr>
<td>Delete Waypoints</td>
<td></td>
</tr>
<tr>
<td>Find</td>
<td>Ctrl-F</td>
</tr>
<tr>
<td>Replace</td>
<td>Ctrl-H</td>
</tr>
<tr>
<td>Find Next</td>
<td>Ctrl-N</td>
</tr>
<tr>
<td>Find Duplicates</td>
<td>Ctrl-U</td>
</tr>
<tr>
<td>Find Duplicated Names</td>
<td></td>
</tr>
<tr>
<td>Print File</td>
<td>Ctrl-P</td>
</tr>
<tr>
<td>Batch Print Maps</td>
<td></td>
</tr>
<tr>
<td>Delete a Map</td>
<td></td>
</tr>
<tr>
<td>Create/Modify Map</td>
<td></td>
</tr>
<tr>
<td>Show All Maps</td>
<td></td>
</tr>
<tr>
<td>Delete a Map</td>
<td></td>
</tr>
<tr>
<td>Print Map</td>
<td></td>
</tr>
<tr>
<td>Display with TDs &amp; L/L</td>
<td>Ctrl-T</td>
</tr>
<tr>
<td>Display with TDs &amp; R/B</td>
<td>Ctrl-R</td>
</tr>
<tr>
<td>Display with L/L &amp; R/B</td>
<td>Ctrl-L</td>
</tr>
<tr>
<td>Display with User Style</td>
<td></td>
</tr>
<tr>
<td>Set User Style</td>
<td></td>
</tr>
<tr>
<td>Display on (Simple) Chart</td>
<td>Ctrl-G</td>
</tr>
<tr>
<td>Display on NOAA Chart</td>
<td></td>
</tr>
<tr>
<td>Chart Whole File (Reset)</td>
<td></td>
</tr>
<tr>
<td>Center Chart on A Waypoint</td>
<td></td>
</tr>
<tr>
<td>Select New Chart Center</td>
<td></td>
</tr>
<tr>
<td>Select Area (To Expand)</td>
<td></td>
</tr>
</tbody>
</table>

The LoranGPS program
I. INTRODUCTION

1. What does the Andren (LoranGPS) program do?

This computer program herein referred to as "the program" helps you organize your fishing spot data (waypoints, a.k.a. readings) accumulated over many years and many trips. It also converts Loran waypoints to GPS and offers the best conversion accuracy available. You can update and print a new book of waypoints whenever you need to. It has routines for organizing, displaying, printing, plotting, and planning that will make your wealth of data work better for you. The program supports Loran data and can convert it to GPS, but the Loran features can be hidden if desired. Some of the features of the program are:

- **Conversion** - The program can convert waypoints from any Loran chain including old A and C chains to Lat/Lon (GPS) and can convert GPS waypoints to Loran TDs. You can precision calibrate the conversions for the highest possible accuracy by training it on good local data. Handles both the old and the new versions of 9960 and 8790 to account for timing changes introduced 1/17/07 by the Dept of Homeland Security.

- **Upload and download** the waypoints stored in a variety of GPS units via cable connection. Currently handling Garmin, Lowrance/Eagle, Furuno, Magellan and NorthStar. Requires a cable (not supplied) connecting your GPS to the PC.

- **Import/export** files compatible with GPS memory cards including C-Map, Garmin, Furuno, Lowrance, Northstar, Simrad, and Raymarine. Also import/export files from other programs like Ozi-Explorer, Maptech, Loran Locator, Offshore Hunter, Text, CSV, Fugawi, Gardown, G7toWin, PCX-5, GDM6, PC-Planner, PC-WindPlot, and others.

- **Organizing, managing** - You can reorder the file by sorting waypoints on any field. Double clicking on a column header will sort the file by that field.

- **Display by list or chart** - Displays file data on the screen in list (spreadsheet) form with Lat/Lon, Loran TDs, and/or Range/ bearing. Also displays the file data graphically on the screen as simple charts with Lat/Lon lines, Loran lines, waypoints, and a coastline. You can also display and print on NOAA charts of the BSB/KAP or NOS/GEO formats.

- **Printing** - You can specify which data fields to print and in what order on a printed list. You can also print maps along with lists of the waypoints that fall within the borders of the map.

- **Mapping** - You can create maps of specific areas that you want to print every time you re-work your book. Maps can be made for any size area and with or without Loran or Lat/Lon lines. Maps are saved as map files for ready retrieval.

- **Search/Replace** - Rapidly find waypoints by key words, phrases, or numbers. Replace numbers, words, or phrases easily.
- Reduce duplicates - Identifies duplicate and near duplicate waypoints so that they may be combined or eliminated.
- Split/Combine - Large files can be split into smaller files or small files can be combined into one large file. Files can be split along Lat/Lon, Loran, or Range/Bearing boundaries.
- Plan Trips - You can plan trips by selecting waypoints from the file. Shows the range and bearing from each waypoint to the next.
- Track Plot - You can plot your present position on the screen and see where you have been. Requires a serial cable (not supplied) connecting your GPS or Loran to the PC.
- Storage - Stores waypoints in files of up to 32,000 waypoints. Each waypoint includes fields for GPS short Name, Latitude and Longitude, Loran TDs, Rating Depth, Description, Icon, Date Code, Comments, a symbol and a color.

Offered by: Andren Software Co.
906 S. Ramona Ave., Indialantic, FL. 32903-3435
All rights reserved. Copyright 1986 to 2010. This printing done in Spring 2010
Warranty: This software is warranted to perform as described. If you find errors in the program or a defective disk, the disk will be replaced. Customer assistance is available at (321)-725-4115.

The author is an aerospace engineer and has been an avid diver since 1971. In his diving activities, it has been important to have accurate location information and to be able to work with large number of waypoints to see what is close by and how good it is. This has been the main reason for the development of the program. The program has been continually upgraded from the time of its first sale in July of 1986. We are responsive to your needs and suggestions.

Carl Andren, the creator of this program is a member of the Institute of Navigation (ION), the International Loran Association (ILA), and the Institute of Electrical and Electronic Engineers (IEEE). He holds 25 patents in electronics engineering including 5 in the IEEE 802.11 technology known as WiFi.

2. Requirements

The program runs on Windows 95, 98 NT, 2K, XP, Vista, up to Windows 7 64 bit. Any computer capable of at least running Windows 95 and having a screen resolution of at least 800 by 600 meets the requirements to handle the program. It will not run on Windows 3.1. It will run on a MAC in a Windows emulator such as Virtual PC or Parallels.

In this manual, words other than titles in bold Arial font generally refer to menu items to select, buttons to push, or text boxes to fill. Menu navigation is represented by the > symbol as in: Edit>Add Waypoints.

This manual is set up with two philosophies. The first 5 chapters are written with the thought: I want to do something, what buttons do I push?. The last chapter is written with the thought: if I push this button, what happens?.

II. SETTING UP THE PROGRAM

1. Installation
Insert the program disk in the CD-ROM drive. If it does not self-start, do the following: Select RUN from WINDOWS’ START MENU, type D:\SETUP (if D is your CD drive letter) in the dialog box that appears and push OK.

SETUP will create a folder called: C:\LoranGPS and automatically install the program files in it. You, of course, have the option of installing the program in another drive or folder such as D:\Program Files\LoranGPS. Not burying it several levels down simplifies support calls. Additionally, the NOAA chart reader cannot handle blanks in the path to the charts, so the above example would be a problem. Further, Windows Vista has limitations on where files can be written to based on permissions. To avoid these issues, use the default installation path.

Once the installation is complete, a new program group called "Andren LoranGPS" is added to the Programs section of the WINDOWS’ START MENU and an icon is placed on the desktop. Leave the CD in the drive during the first running of the program so that it can fetch chart and other files.

Run the new program by double clicking the blue and green Earth icon on the desktop. When it first runs, the program will alert you that the User Preferences have not been set. Select Yes and change any of the preferences to your settings. After the HEADER is changed, you will no longer get this alert. See chapter 2 for details on personalizing the program.

Upgrading
If you are upgrading from an earlier WINDOWS version of Andren LoranGPS, SETUP will replace some program files and may require re-inputting user preferences. You may be required to uninstall the original version. Doing so will not, however, remove or replace your data files.

If you are upgrading from the DOS version of the program, SETUP will not remove the DOS forms of the LORAN program and associated waypoints files, but will leave them in their original folder (that is normally C:\Loran). When you exit User Preferences, (used for personalizing the program), it will look for DOS version files in C:\Loran and will ask if you want to batch update them at that time. After you are satisfied that all files have been transferred and your data and maps are safely converted, saved, and backed up, you can delete the C:\Loran folder and everything in it.

Getting Help
The help system is available at any time with key F1 and may show help on the topic that is presently the focus of attention. The help system is more complete and has more current information than this
manual and should be consulted whenever you have questions not answered by this manual. You can also print the more complete manual from the copy in the program folder via the HELP menu.
2. Personalizing the Program (Setting Preferences)

**TOOLS>USER PREFERENCES** personalizes the program with information about the areas that you fish. The program is shipped with sample information for a similar area. Enter your personal information in place of this sample where appropriate. Some of this information is used for initializing new files and the rest applies to general program operations. This section describes some of the selections on the **USER PREFERENCES** screen and the things you need to change when you first set up.

### Andren LoranGPS User Preferences

- **Printout Header:** Enter the header for all the pages of your book printed by the program.

- **Center Latitude/Longitude:** Enter the general area you fish in. The program needs to know the general location of your working area in order to correctly do Loran to Lat/Lon conversions and to check for errors in data entry. For the center, pick a point in the area you fish and enter the approximate Latitude and Longitude. Use positive numbers for N and W and negative for S and E. You can enter Lat/Lon numbers in any of several forms:
  - DD.DDD degrees (and fractions)
  - DDMM.MM or: DD MM.MM degrees, minutes with or without a space or dash
  - DD MM SS.SS degrees, minutes, seconds with two spaces or dashes

- **Inlet Name:** Enter the name and location of a frequently used inlet for use as a reference point in Range and Bearing calculations.

### Loran Chain Choices: Favorite one is Red.

<table>
<thead>
<tr>
<th>Num</th>
<th>GRI1</th>
<th>GRI2</th>
<th>TD1</th>
<th>TD2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>7980W</td>
<td>7980X</td>
<td>14209</td>
<td>31047</td>
</tr>
<tr>
<td>2</td>
<td>7980W</td>
<td>7980X</td>
<td>14209</td>
<td>45035</td>
</tr>
<tr>
<td>3</td>
<td>7980W</td>
<td>7980Z</td>
<td>14209</td>
<td>63076</td>
</tr>
<tr>
<td>4</td>
<td>7980X</td>
<td>7980Y</td>
<td>31047</td>
<td>45035</td>
</tr>
<tr>
<td>5</td>
<td>7980X</td>
<td>7980Z</td>
<td>31047</td>
<td>63076</td>
</tr>
<tr>
<td>6</td>
<td>7980Y</td>
<td>7980Y</td>
<td>45035</td>
<td>63076</td>
</tr>
<tr>
<td>7</td>
<td>9930W</td>
<td>9930Z</td>
<td>11995</td>
<td>70330</td>
</tr>
<tr>
<td>8</td>
<td>3H0</td>
<td>3H1</td>
<td>1875</td>
<td>3822</td>
</tr>
</tbody>
</table>

- **Hide Loran Features**
- **Set Duplicates**
- **Set Number Formats**
- **Set Conversion Method**
- **Select Loran Chains**

**2.1 Printout HEADER:** Enter the header for all the pages of your book printed by the program.

**2.2 Center Latitude/Longitude:** Enter the general area you fish in. The program needs to know the general location of your working area in order to correctly do Loran to Lat/Lon conversions and to check for errors in data entry. For the center, pick a point in the area you fish and enter the approximate Latitude and Longitude. Use positive numbers for N and W and negative for S and E. You can enter Lat/Lon numbers in any of several forms:

- DD.DDD degrees (and fractions)
- DDMM.MM or: DD MM.MM degrees, minutes with or without a space or dash
- DD MM SS.SS degrees, minutes, seconds with two spaces or dashes

**2.3 Inlet Latitude, Longitude and, Name:** Enter the name and location of a frequently used inlet for use as a reference point in Range and Bearing calculations.
2.4 Hide Loran Features
If you don't want to see Loran based features, then push this button. It hides all Loran information, to simplify the display. It then makes the next two settings disappear.

2.5 (Loran) Chain Choices: If you are in the Southeast US and are using the 7980 Loran GRI, you can skip this section. The program needs to know what Loran chains you will be using; both to check your entries and to do the calculations. Typically, the installation is pre set with the appropriate chains for the section of the country you are in. See the reference chapter to get more details on programming chains if you are in another part of the world.

2.6 Set Favorite (Loran) Chain: The Loran Chain is an artificially selected number from 1 to 8 that only has meaning to this program. On the chain spreadsheet of the User Preferences window, click on the row of the Loran chain you will use most frequently. This will highlight it in red. It will be the default chain choice for new files, but each file can have its' own favorite.

2.7 SAVE SETTINGS, and OK, DONE save the preferences and exit. If you mess up and want to reset to the original values or if the User Preferences file is corrupt, push RESTORE SETTINGS. This will open a dialog where you can find the original file on the CD and reset to those default settings.

On exiting this screen the first time, the program will check the CD for chart files and waypoint files it can move into the program folder. The CD contains a selection of NOAA charts you may need. If you don't want to load up the hard drive with chart you may not need, then you can always fetch the ones you want later with the File>backup/restore menu item.
III USING THE PROGRAM

1. Introduction
You will mainly use the program to create and maintain a book of waypoints (readings) containing your marine fishing information. It comes with examples of the files you will set up for your book. This chapter gives information on how you can start your own files and work with them. Additionally, it can help you manage the waypoints in your GPS and/or move them from one brand to another.

2. Learning to Use the Program
In order to do anything useful with the program you must first create a new file, open an existing data file, or import data from another document (or from a GPS). The files: TEST_File.DBF and TEST.MAP are available to help you learn and become familiar with the features of the program. The program is set to open the test file when you initially start up. If no file is displayed, select FILE>OPEN FILE and then choose TEST_File.DBF. Once the file is open, the program will initially display the sample file in the spreadsheet mode. This quick tour will show you many of the features of the program.

1. Scroll through the file and try editing some of the waypoints and try other program functions such as EDIT>Add Waypoints. Add waypoints in the vicinity of the ones in the file.
2. Double click on the spreadsheet column header where it says LON to sort by longitude.
3. Select DISPLAY>Display on Chart. This will create a chart of the waypoints
4. Select CHART OPERATIONS>COASTLINE>USA Coastline>Hi Res to put the coastline on this display.
5. Select CHART OPERATIONS>Zoom>2X. Then push the up arrow to pan the display.
6. Select CHART OPERATIONS>Select Area. Then position the cursor on the corner of an area of interest and press the mouse button. Hold down the left mouse button while dragging open a band encircling the points of interest. When you release the mouse button, it will zoom and pan the display to show you the area inside the rectangle, filling the screen.
8. Return to the spreadsheet display by clicking Display>Display User Style. Try double clicking on the column header for each column to see it sort the data.
9. Select Display on NOAA chart and pick the test NOAA chart to show the Test file on.
10. Try Chart Operations>Center chart on waypoint #? and pick waypoint 10. This will pan the chart to that waypoint.
11. Go through the various menus and try all the operations that you might use. Don't be shy, if you mess up, nothing valuable is lost since the test file is all bogus data.

3. Building your own files

To start your own file, select **FILE>NEW FILE**. Each new file will inherit properties from the **User Preferences**, but you can change them to suit the needs of this new file. Give the file a name and change the other properties as needed and push **OK**. Next, use **EDIT>ADD WAYPOINTS** to put in waypoints. On this screen, you have the choice of putting them in as Loran, as GPS, or both. Then just type in the data you want to put into each waypoint. They are saved to disk as you enter them. The program will do its best to decipher your input and fit it to the desired information. If it has a problem with an entry, it will show you the difficulty that it is having. If you are just trying to work outside the bounds of your normal area, ignore the message, but if not, read it and try to see just what is wrong.

You can enter Lat/Lon numbers in any one of four distinct forms. Use positive numbers for N and W and negative for S and E. For example, the following are all equivalent and valid:

- 28.9873 degrees (DD.DDDD)
- 2859.238 or: 28 59.238 degrees, minutes (DDMM.MMM)
- 28 59 14.28 degrees, minutes, seconds (DD MM SS.SS)

You can use dashes in place of the spaces if you wish. If the program sees a number with two spaces it will assume that it is the last type. A common mistake is to leave out the periods that are not prominent on the GPS's display. Unfortunately, you cannot do that here. So, if you put in a number like: 28 59 238, the program will complain that there are more than 60 seconds in the number as it will think the 238 is seconds. It might, however, accept 28 59 001 as valid when it is not, so use the accepted forms.

The most common form of GPS display is the third one (28 59.238) and this one has a period. I like the second one since it is more compact.

You have choices for entering some other characteristics of the waypoint such as the name, color, the date code, depth, Icon, and a symbol to represent the waypoint. Use the function keys F2 through F10 to type common words or phrases. These can be programmed.

4. Editing your files

The file, once created can be edited easily on screen in the spreadsheet. Just move the mouse cursor to the entry to be edited and double click to place the cursor where you want it. You may have to delete or backspace over information already there.

Some of the information is computed and cannot be edited unless you want to change the character of the waypoint. If, for example, you want to correct the Latitude of a waypoint originally entered as Loran, then you must know the right Latitude or you wouldn't be doing that. In that case, you go ahead and edit the Lat/Lon and that will turn the waypoint into a calibration waypoint where both Loran and Lat/Lon are assumed correct as entered. No further calculations will be performed on those waypoints except for figuring range and bearing.
5. Reorganizing your data

The program will sort on any column when you double click on the column header. Double clicking again will reverse the sort. For more complex sorts, check out File>Sort File. You can also use File>Combine or File>Split to make up different groupings.

After sorting the data, you can purge or merge duplicates with Edit>Find Duplicates. It will scan the file and show which waypoints have other waypoints very close by.

6. Changing how the numbers are displayed

There are many different ways to describe Latitude and Longitude. They can be in degrees only, in degrees and minutes or degrees, minutes and seconds. Most GPSs default to degrees and minutes. The program has a Display>Number Formatting screen that lets you pick how your numbers will be displayed. Even though you pick one of these forms for display, the program stores the information internally in a standard form. You can enter data in any of the other forms and it will be accepted and converted to the standard form.

Range can be in statute miles, nautical miles, or kilometers. If the numbering or distance formats are not the way you want them, change them. You can also set the length of the GPS Name field here.

7. Showing the waypoints on a chart

Once you have some waypoints in the file, you can display them on a chart. Charts can either be a simple chart created by the program or a raster digitized NOAA chart. The program will scale a simple chart big enough to show all the waypoints on the screen or will show a NOAA chart at a nominal zoom level. Then you use the Pan and Zoom capabilities to make the chart show just the area you want to see. There are several ways to both pan and zoom. To pan, you can use the cursor control keys to move the viewpoint up, down, left, right for the simple chart or the scroll bars for the NOAA chart. You can also make where you click the cursor the center of the chart or pick a specific waypoint to center on. Try the selections on the Chart Operations Menu to see what is available. When working from a large-scale chart, Select Area is one of the more useful tools in that, you can pick a specific smaller area and, in effect, pan and zoom at the same time. Another tool is Identify Waypoint that, when clicked near the waypoint, will show some of the waypoint's data at the bottom of the screen.

Select Chart Operations>Coastline and put a coastline on the simple chart. You can also use Chart Operations>Charting Options to select or deselect what is shown on the chart such as Lat/Lon lines, Range/Bearing lines, or Loran lines.

8. Making Maps

For our (Andren Software's) convenience, we make the distinction that charts are for the moment and maps are permanent even though they may show the same thing. The difference is that you will save maps on the disk so they will be the same every time you print your book. A good practice is to create (with Map>Create Map) one overall map with the waypoints as dots to see the overall reef layouts. Then make a sequence of maps with the waypoints as numbers or names that slightly overlap and show all the area in a scale of perhaps 10 miles on a side. Finally, make maps that detail the concentrated
reef areas on a scale of 1 to 2 miles on a side. These might be even more overlapped to avoid missing any points.

An easy way to get started with maps is to pan and zoom a chart to show what you want on the map and then use **Chart Operations>Make this chart into a Map.** This brings you to the **Create Map** screen with the map borders already determined.

For convenience, you can show the outlines of all your maps on the screen or paper at the same time with **Map>Show All Maps>Show all in Folder.** This will let you see where your coverage may be lacking and helps you find a specific map you may be looking for.

### 9. Setting up to print your book

To begin making a book of your fishing spots, you need to plan how your data is to be organized. You could put everything in one huge file or split it up into zone or regional files based on which inlet you would use for the area. Alternatively, you can split the file on reef lines or depth zones, such as: 60 ft reefs, 90 ft reefs, etc. Then you can organize the files by use of the **File>Split** or **File>Combine** capabilities to make the individual files.

Next, you would make a set of maps to best display the data for each file in your book. To make printing the maps easier, the program allows batch map printing from a list (see reference, chapter VI). Make a separate list for each waypoint file. Finally, print the listings and maps from the lists. Remember that the printed page has its own organization and does not necessarily follow the way you set up the screen display. Use **File>Printing Format** to arrange how your data will be placed on the page and use **File>Printing Format>Print Preview** to verify that it will print the way you want it.

### 10. Converting from Loran to GPS

The program automatically converts Loran waypoints (TDs) to GPS (Lat/Lon) as they are added to a file. In the event that it cannot, the usual reasons are that the number is mistyped or the waypoint is very far from the center Lat/Lon. If the program can't convert a waypoint, it may bring up a warning that something is wrong with the waypoint. Once the problem has been corrected, the Lat/Lon should appear in the spreadsheet display as each waypoint is entered.

If waypoints are entered as Lat/Lon, they are automatically converted to the appropriate Loran numbers if the check box on the **ADD WAYPOINTS** screen is checked. If you enter waypoints as Lat/Lon and they are not converted to TDs and you later want to convert them, use the **TOOLS>CONVERT FILE** (to another Loran chain) routine.

### 11. Calibrating the Conversions

Converting Loran to Latitude and Longitude involves complex geometry that the computer can handle with great precision. The hard part is that the Loran waypoints, while stable and repeatable, are not accurate in a geographical sense. They can be as much as a half-mile off from where they should be based on the distance to the Loran stations and the speed of light. In the 1980s the US government published tables of correction factors (called ASFs) to fix this so that their maps could be shown with the corrected Loran lines on them. The program has the full set of those tables built-in, but they are only good for about 250 ft of accuracy. These tables cover only US loran chains and only over water.
To get closer to the repeatable accuracy that we experience with Loran, the tables must be improved by calibration. Some areas have already been calibrated through use of customer supplied data. You can do this yourself by training the program on local data. Just enter waypoints where you know both the correct Loran and Lat/Lon information. Be sure that this is from a known source that used a Loran and a GPS on the same spot. Published data is questionable unless the provider guarantees that real hardware was used to collect the data and that it was not itself a conversion. We have seen many lists on the Internet that contained poorly converted Lat/Lon information.

Once these calibration waypoints are in your data file, use Tools>Calibrate Conversions. It gives you the option of either calibrating the government tables or using the calibration data directly (single ASF per file). See the chapter VI Reference section for more information on this.

12. Planning a Trip or Route
In the Trip Planner mode, the screen is split into two spreadsheets. The upper one shows the source file and lower one, the trip plan. You just click on waypoints on the file spreadsheet and they will be placed on the trip spreadsheet. You can also type in the waypoint numbers and they will be placed on the trip plan. In the trip planning mode, the range and bearing is from one point to the next unlike the regular mode where it is all points to the reference point.

13. Showing range and bearing
Range and bearing is normally shown from each waypoint to the inlet or reference point. The program allows you to double click on the range or bearing of any point to make that the reference point. This makes it easy to find the range from that point to all others.

14. Setting the Range/Bearing reference
Whenever range and bearing is shown in the spreadsheet, the reference point for the calculation must be known. Initially it will be either the one in the file preferences or the last reference point used. You can set a new R/B reference from Display:Set R/B reference. This form has places to enter the reference point as Loran, Lat/Lon, or a waypoint number. Alternatively, you can pick one from a list of already saved reference points. Lastly, you can set it directly on the spreadsheet by double clicking on any waypoint's range or bearing making that waypoint the reference point.
IV Menu Choices (Reference)

1. The Main Menu

<table>
<thead>
<tr>
<th>FILE</th>
<th>EDIT</th>
<th>DISPLAY</th>
<th>MAPS</th>
<th>CHART OPS</th>
<th>TOOLS</th>
<th>PLAN TRIP</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>New File</td>
<td>Cut</td>
<td>Display with TDs L/L</td>
<td>Create Map</td>
<td>Chart Whole File (reset)</td>
<td>User Preferences</td>
<td>New Trip</td>
<td></td>
</tr>
<tr>
<td>Open File</td>
<td>Copy</td>
<td>Display with TDs R/B</td>
<td>View Map</td>
<td>Center Chart On Waypoint</td>
<td>Calibrate Conversions</td>
<td>Continue Trip</td>
<td></td>
</tr>
<tr>
<td>Save File</td>
<td>Paste</td>
<td>Display with L/L R/B</td>
<td>Show all Maps</td>
<td>Select New Chart Center</td>
<td>Recalculate L/L</td>
<td>Save Trip</td>
<td></td>
</tr>
<tr>
<td>Save File As</td>
<td>Add Waypoint</td>
<td>Display with User Style</td>
<td>Delete a Map</td>
<td>Zoom</td>
<td>Convert File</td>
<td>Print Trip</td>
<td></td>
</tr>
<tr>
<td>Backup/Restore Files</td>
<td>Delete Waypoint</td>
<td>Set User Style</td>
<td>Print Map</td>
<td>Select Area</td>
<td>Re-Sequence Date Code</td>
<td>Quit Planning</td>
<td></td>
</tr>
<tr>
<td>Delete a File</td>
<td>Find</td>
<td>Display Simple Chart</td>
<td>Batch Print Maps</td>
<td>Identify Waypoint</td>
<td>Import File</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save File As V5 or V6</td>
<td>Replace</td>
<td>Display on NOAA chart</td>
<td>Mapping Options</td>
<td>Make Chart Into a Map</td>
<td>Export file</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find Missing Files</td>
<td>Find Next</td>
<td>Set Range Bearing Reference</td>
<td>Print This Chart</td>
<td>Tag Waypoints</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>File Properties</td>
<td>Find duplicates</td>
<td>Number Formats</td>
<td>Coastlines</td>
<td>Swap TDs</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Combine Files</td>
<td></td>
<td>Features</td>
<td>Swap/Fill Fields</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Split File</td>
<td></td>
<td>Tracks</td>
<td>Color all Waypoints</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sort File</td>
<td></td>
<td>Track Plotting</td>
<td>Other Boat</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print</td>
<td></td>
<td>Charting Options</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Printing Format</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Last 3 files loaded</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Most of the routines of this program perform work on the data files you create from your own numbers. Program routines and functions are controlled from the main window that displays the
**MENU** at the top of the screen along with a spreadsheet or chart that displays the waypoints in the file you have open. The **MENU** choices are diagrammed in the table above.

The top row of the **MENU** table shows the menu headings and the following rows are the drop down choices.

**In order to do anything useful with the program you must first open an existing data file, create a new one, import one, or download one. The program will attempt to open the last one worked on when it is started.**

See chapter VI for the Menu Choices where you will find a description of how each menu choice works. This is a great reference to better understand the options like importing and exporting or uploading and downloading.

### 2. The NOAA chart Menu

When you choose **Display on NOAA Chart**, you will get a new screen with it's own menu bar. Many of the operations here are identical or similar to the menu choices on the Main Menu. Both the main screen and the NOAA screen can be active at the same time. However the program can get confused if you work on the simple chart and the NOAA chart alternatively while both are open.

NOAA charts can be downloaded free off the internet from [http://www.ngdc.noaa.gov/mgg/bathymetry/maps/nos_intro.html](http://www.ngdc.noaa.gov/mgg/bathymetry/maps/nos_intro.html). The chart types that work with this program are known as BSB/KAP or NOS/GEO.

The NOAA chart display consists of the digitized chart and overlays added by this program. If the chart is scrolled, the overlays can sometimes get smeared, so a Refresh Chart menu item is available to clear up the chart. This reset function is also useful if you add new waypoints to the file while the NOAA chart is being displayed.
V. Additional Information

1. What Are ASF Correction Factors?

ASFs (Additional Secondary Factors) are correction factors used in the Loran to Lat/Lon conversions to make the conversion more accurate. They compensate for the fact that radio propagation over land and over water will distort the Loran signals as they travel to you. This distortion can be as much as ± 5 microseconds and can cause the Loran to Lat/Lon conversions to be very inaccurate. The ASF tables created by the government in the 1980s assumed the land features then existing. Much coastal development has taken place since then and the new structures effect the accuracy of Loran signals. The program has the ability to upgrade the government tables by using calibration waypoints to teach the program what corrections are necessary.

When using the program to convert Loran numbers using calibrated ASF tables, it is possible to achieve an accuracy of better than 0.2 microseconds for "C" waypoints (about 100 ft.) and 2 microseconds for old "A" numbers (about 1000 ft.). Keep in mind, that, the old "A" numbers were never very accurate to begin with and the calculations do not improve on that accuracy even if they show lots of decimal places.

Where do you get the ASF numbers? First, the program has a built in table of ASFs derived from government tables. These tables are reasonably accurate, and can provide an accuracy of around 250-ft. They were derived in the early 1980's before the availability of GPS so they contain a lot of educated guesswork. Also, the tables are not available for all Loran chains. ASF tables calculated from your own calibration waypoints are much better and achieve an accuracy of better than 100-ft in most cases (but no better than the original Loran repeatability).

Land based calibration waypoints are not desirable since Loran signals are distorted near shore and are strongly influenced by overhead power lines, buildings and bridges. A Differential GPS (DGPS) or WAAS waypoint is the best source of the Lat/Lon part of a reference waypoint, whereas a standard GPS waypoint has about the same accuracy as Loran.

When comparing the Loran to LAT/LON conversions of your GPS or other sources with the program you may see differences. Only if they are using the same ASFs and the same formulas will they be in close agreement.

2 Calibrating the Conversions

The program uses calibration waypoints to achieve the best accuracy in Loran to Lat/Lon conversions. It has the full set of Government Defense Mapping Agency (DMA) Additional Secondary Factor (ASF) tables that are stored in 5-minute (5-mile) increments. These tables have been derived from the printed books for the chains: 5930, 5990, 7960, 7980, 8970, 9940, and 9960. They were scanned into
the computer and processed by optical character recognition (OCR). Be advised that there may have been some errors in this process even though we were very careful in examining the tables after the OCR process. There is a feature available during the calibration process to examine them. They are all that is available, and their accuracy is only about 250 ft. You may get better accuracy since the program has been pre-calibrated for areas where customers have donated appropriate data to us. Keep in mind that there are two sets of station parameters for chains 9960 and 8970. They are carried in the program as, for example, 9960b (for before 1/17/07) and 9960a (for after 1/17/07). The government made a timing change on that date. Calibrating with the wrong set will put you off by about 400 ft. Only one set of ASFs is currently held, so make sure your data is entered with the right versions of these chains. That is, enter your old (pre-2007) data with 9960b and any newly measured calibration data with 9960a. Timing changes may occur for other chains in the future.

There are three optional calculation methods used in the program. Calculation method 2 uses these DMA tables as-is in the conversion calculation. Using these tables will provide about 250 ft of conversion accuracy compared to about 1500 ft without using any ASFs. Of course, calibration does not affect conversions using this method.

To get even better accuracy, the program has the capability to learn from your reference waypoints and use them to either calibrate the DMA tables or calculate a new set of ASF values to use. These are called calculation methods 1 (and 3 explained later). To do calibration, you need to enter waypoints taken offshore with both a GPS and a Loran on the same spot or get this data from someone else. These simultaneous waypoints of Loran and GPS are the ‘truth’ by which you will calibrate the program and also check to see that it is converting the waypoints correctly.

You can enter this calibration data into the program as new waypoints using both Loran and Lat/Lon or you can just correct existing waypoints. For the latter, you correct the Lat/Lon on the spreadsheet, which then promotes that waypoint to calibration status. In either of these procedures, you will be asked where you got the Lat/Lon. If it was from a Differential GPS (DGPS) or WAAS, it will be treated with greatest respect and given a high quality factor. If it came from a less accurate source, a lower quality factor will be assigned to it. Calibration waypoints will never have conversions done on them unless you demote them to non-calibration status.

A two-digit chain number identifies calibration waypoints where the leading digit is assigned based on the source. For example, a chain number of 96 indicates that the waypoint is a calibration waypoint using a DGPS or WAAS and Loran chain 6. Generally, the lower the leading digit, the less the program trusts the data. Changing the chain number back to a one-digit number (such as 6) demotes the waypoint to non-calibration status and indicates that loran chain 6 is being used as the source data.

When you push the Tools>Calibrate Conversions button, several operations are performed. The calibration data is first scanned for errors. The ASFs of all the calibration waypoints are calculated. Then the program calculates an average of the ASFs for each Loran slave station for all the calibration waypoints weighted by the quality factor. If any of the ASFs is in gross disagreement with the average value, the waypoint is brought to your attention for possible demotion. All demoted waypoints are ignored in the calibration process. They are usually demoted to be loran waypoints.

As a part of the calibration process, a file that contains all the calibration waypoints is created and maintained. It will contain all the calibration waypoints of all the files you have calibrated. Therefore, it will apply calibration waypoints from one file to another if they are in the vicinity. If you suspect that this file has gotten corrupt or contains waypoints you no longer want in the calibration process,
you are given the option to erase the old calibration file (Calib~ASF.DBF) and begin anew. You can also open it and edit it directly to delete questionable points.

**Calculation Method** 1 uses each of the calibration waypoints to adjust the DMA table values near them to achieve perfection. The influence of each calibration waypoints falls off with distance, so that distant ASF values will not get adjusted as much. The influence extends to at least 40 miles. This procedure creates a user adjusted ASF file called "ASFuser.bin" that contains the calibrated tables. Once the tables have been adjusted, the program recalculates all the TD to LL conversions in the file using the new tables and uses the calibrated tables for all future conversions. To apply the calibrated tables to files previously converted with the old tables, open them and use **Tools>Recalculate LL**.

If you are using **calculation method** 3 for conversions, the government tables are ignored and a single ASF value is applied across the whole area. For this, the average ASFs calculated above are used to recalculate all the conversions in the file and the process is finished. No updates are made to the user-calibrated tables in this case. This method is useful where the ASF do not vary much over the area in question and you only have calibration points in one small part of the area. It is necessary to use this method if your data strays outside the area covered by the tables.

The versions of the program before 5.0 only used **calculation method** 3. Examine the government (DMA) tables for your area and see if all of the ASF factors are more or less the same over the area. This technique does very well in some areas and insures that even waypoints far from the calibration way points are adjusted.

The Calibration selection screen has a button that allows you to examine the ASFs of both the government and user calibrated tables for your area. This will better inform you as to the ASF values that will be used and to give you a feel for the variability of the values over your area. In some areas, the ASF values are very uniform across the area and a single value will be a good choice. In other areas, the ASF values vary widely from place to place and you will be much better off using the calibrated tables. The example below shows one such area where the values are not uniformly distributed. The tables are in 5-minute increments (5 minutes is about 5 nautical miles). This table shows a jump from 1.9 to 2.3 microseconds in just 5 miles. That’s a potential error of around 200-ft if the same ASF is used for both areas.

The user-adjusted table is, by the way, filled-in more than the DMA tables. The DMA tables are blank over land. This filling-in was done by extrapolation. It was done to help the program to avoid a kink...
in the Loran lines for a map or chart when they extend over land. It was not meant to provide accurate conversions over land.

When examining the ASF tables, note that they are arranged in 1-degree Lon/Lat blocks where the block designator is the upper left-hand corner of the block. This means that to see 81 20.0W, 28 35.0N, you need to look at the 82/29 block (round up both numbers). You have choices of any of the 7 basic Loran GRIs (7930 - 9960) and any of the up to 4 slaves (W - Z).

An examination of all the DMA ASF tables show that the ASF factors never get to be greater than +/-5.5 microseconds and generally never change more than +/-1.5 microseconds from one 5 minute block to the next. A more normal case is an ASF of 2 microseconds or less and no more than 0.2 microseconds change block to block. If the ASF pattern shows much variation over the area of interest, then a single ASF value per file is not a good choice. Some areas show wild variations and must have the more complete user ASF tables. Experiment with the results to see which best suits your situation. The graphic below shows some Canadian data on ASFs in an area where we do not have tables. This graphic will give you a feel for the variability of ASFs. It amply shows how much land areas influence the Loran signals.

A calibration report is generated to show you what accuracy the process might achieve. It does this by taking all the calibration waypoints in the file and calculating the Lat/Lon from the Loran as if the Lat/Lon was not known. Then the distance from the calculated to the real position is figured for each one. The distances for all the calibration waypoints are averaged and both the average and worst
distance is reported. By doing the calibration with each of the calibration methods above and examining the calibration report, you can find the most accurate method for you.

3. How to Scale and Manage Maps

Maps are sized to fill the paper to your margin settings. The scale of the map can be set to cover the area you want to show but remember the screen and paper are different shapes. The simple maps created by the program are Mid Latitude projections so one degree of longitude is smaller than one degree of Latitude. NOAA maps use Mercator projections that make the spacing between the Latitude lines vary slightly between the top and bottom of the map. The difference between these two types of projections is minor over the typical area covered by a fisherman.

The mapping routine in Maps>Create Map uses your default center Latitude to figure the map width rather than using the actual middle of the map. Therefore, all the maps you make will have the same width to height ratio allowing you to easily paste them together.

If you have trouble figuring out what Lat/Lon to use to make a map, use the Display>Display On Chart feature to see where your waypoints are. Pan and zoom around the chart until you are satisfied with the area displayed. Then select Chart Operations>Make This Chart into A Map to make a map of that area. Keep in mind that the map that will be created may be about twice as tall as the screen (unless you use landscape orientation) and may show more waypoints. Also use the MAP>Show All Maps feature. It shows all your saved maps as outlines on one chart. From this you can see where more maps are needed or where you need to make adjustments to maps to get the best coverage.

If you try to make a map of an area that encompasses one of the Loran stations being used, or if the lines are highly curved, the Loran to Lat/Lon computations may fail, which means that the map will have some missing Loran lines. You will be able to see this when you Map>View Map. Changing chains or map areas may rectify the situation.

4. How to Import a File Using Excel (2003 or earlier)

The program comes with many capable importing routines, but it can't handle all possible situations. Microsoft's EXCEL (2003 or earlier) is an excellent tool for importing and exporting between the program and arbitrary text and formatted files like found on the Internet. When importing and exporting data via EXCEL or any other program that recognizes the dBase file format, the following considerations should be understood. The Andren program uses the universally recognized dBase file format but does not have format flexibility. It will not load the file if the number of fields and the field structure is not right. On importing is there a need to be sure the number, type, and order of the fields are right. This section details how to insure that.

You don't have to use the Excel technique as you have the alternative of importing as a CSV file even if the original data is in Excel. See the text importing section (section VI.6) or the help file for details. If the data is in Excel and you want to simplify the importing, then save it as "CSV (comma delimited) (*.csv)". If the description fields have commas then replace them with something else like semicolons. Having extra commas in a CSV file will cause the file to be read incorrectly.

For importing using EXCEL, create the proper kind of dBase file with the program and then paste data into it using EXCEL. The procedure is as follows:
1. Start by making and saving a file with at least as many sacrificial waypoints in it as in the data base you are importing. You can **Combine** the TEST_FILE.DBF file with itself repeatedly in order to get a big enough file.

2. Open this file with EXCEL. You will need to change the **Files of Type** to dBase (*.DBF) in Excel's **Open file** dialog box.

3. Also open (in Excel) the source file that has the data you want to import.

4. Then copy the source file data column by column and paste it into the appropriate column of the Andren LoranGPS file. Move down one row when copying, and leave the first file row unchanged. It contains the **file properties** for the program and should not be modified. Use the **Window** menu to toggle between the files. If you do not have data for specific fields, leave them blank. The minimum fields required for a waypoint are the Lat and Lon or TD1 and TD2. All other fields can be blank, but a Name or Description is desirable.

5. Delete any of the old information that you do not want in the new file.

6. After you have coppied and pasted the field information into the dBase file, fill in the **Chain** column with the appropriate chain numbers (0 for Lat/Lon and 1 through 8 for Loran TDs). EXCEL can easily fill a whole column with the same number.

7. Once the file has your data added, highlight the columns that have numbers in them like TDs or Lat/Lon. Then go to the Format menu, select Cells, and make sure the selection is "numbers" with sufficient decimal places. Note: Excel 2007 will not save the file in dBase form. Then save and close the file in EXCEL and open it with the Andren LoranGPS program to verify that it is all there. If the Lat/Lon fields (or TD fields) are zero or wrong, don't worry, you can calculate the Lat/Lon (or TDs) using **Tools>Recalculate Lat/Lon** (or **Tools>Convert File**). If the fractional parts are 0, then you did not follow the advice above. One additional caution is that if the copied and pasted numbers have a leading space, they may get treated as text even when pasting into a number column. The easiest way to fix this is to get rid of the leading spaces.

8. Make sure the center Lat & Lon, Inlet name, and Inlet Lat/Lon are right in the file by examining **File>File Properties**. If they are not right for the data you are importing, fix them.

9. If the new file is longer than the imported information, trim it using **File>Split File** or just delete the extra waypoints one by one.

If you still have trouble with conversion of your files, a conversion service is available at low cost. Several import routines have been developed for special file organizations, so we should be able to easily convert your database into the right form by using one of these programs. E-mail or call for information.

### 5. Where Did the Formulas come from?

The program uses computational algorithms derived from a program written for the Navy by A. C. Campbell of the Geodesy Division of the Hydrographic Surveys Department, Naval Oceanographic Office in 1962. The program used an inverse routine for hyperbolic navigation developed by Emanuel Sodano. The program performs hyperbolic geometric calculations on an oblate spheroid based on the WGS-84 measurements of the Earth's size and shape. The Campbell algorithms are those used by the Defense Mapping Agency and NOAA. This conversion routine requires an estimate of the initial geographic position (Center Lat/Lon) for Loran to geographic conversion. The estimate should be

---

**The LoranGPS program**

V. Additional Information • 23
within about 100 miles of the point converted, to insure converging on the right solution. Where two solutions exist nearby, as is the case near the Loran stations, the equations may not reach a solution and will return an answer of zero.

NOAA has a free program called POSAID on their web site that uses the same formulas as this program. It is a DOS program and not very convenient to use and does not have ASFs.

In order for the program to compute the LAT/LON of a given Loran waypoint, the position of the Loran stations must be known. This data is contained in a file that is accessed through the User Preferences routine. It selects those needed for your choice of Loran chains. The file contains all stations reported to the author by the US Coast Guard and Megapulse Inc. which includes all old A and C stations as well as stations in foreign countries, some of which are now out of service.

6. Register Your Copy

Thank you for buying the Andren LoranGPS program, we hope you enjoy working with it. If the program’s opening screen has your name and address in it, you do not need to register it. Otherwise simply write down the information on who you are and where you bought it and send it by regular mail (or e-mail it to sales@andren.com). The information we need is name, address, and phone number, where you bought it and the serial number that is on the opening screen.

Registering will insure that you are notified of any updates or problems found. Upgrades will be available at a nominal price to registered users. Notices can only be sent to users we have addresses for, so let us know where you are, and keep in touch when you move.

An Internet WEB site is available at: http://www.andren.com. The web site will have the latest information on the program as well as news on updates as appropriate. Downloadable free updates for bug fixes and minor changes are also available on the web site under program support. Generally you are entitled to free updates for a couple of years after purchasing the program.

7. Tips and Tricks

Since the program added three new fields in version 7.0, you may need to fill them if you are upgrading. To fill the name field, there is a selection: Tools>Swap/Fill Fields. This allows you to specify how you want the fields filled. If nothing is specified for the Name field, it will be linked to the waypoint number. This linking allows you to name some of the waypoints and leave the rest linked. The way linking works is that unless you enter a name in the Name field, it behaves just like the number column on the left side of the spreadsheet. If you put in a name, thereafter the Name sticks to that waypoint. As an old V5 of V6 file is opened, the Icon field is set to "x" and the depth field is left blank. If you earlier put the depth into the Rating field, you can now swap these two fields.

If you get a file of waypoints from a friend, you can Tools>Tag or Tools>Color All of his waypoints prior to combining them into your file.

If you later want to take them back out after blending them in, you can File>Sort by color or TAG and then File>Split the file by waypoint number.
If you work in the North East US, take a look at the web site and read the selection in the FAQ called "It's not your Loran". This will alert you to important changes in the Loran system effecting your numbers by 400 ft or so.

Make a cheat sheet for the function keys. Cut a long narrow sheet of paper and put the definition of each of the F2 through F10 keys on it. Better yet, make 2, one for general operations and one for the Edit>Add Waypoints quick typing aids.

If you accidentally delete a waypoint in a file that is not numerically or alphabetically sorted and want to restore it to the same place it was, do one of the following. Add the waypoint and give it the missing date code and then File>Sort by Date Code. Alternatively, File>Split the file by waypoint number at the point you want to add the waypoint. Then Edit>Add the waypoint to the first part and finally File>Combine the second part with it.

To make a graphic of where your maps are, use MAP>Show-All-Maps. You can print this graphic.

Remember, it is important to keep a record of all the data you have, even the dud ledges. Give them a low rating, and then, when you accidentally come across them in the future, you will have something on them. Otherwise, you may be constantly rediscovering them.

If you are uploading a file to a GPS, leave some waypoint memory empty so you can add instant finds. You can also make your inlet(s) and fog course from the inlet to the dock the first or last few entries in the uploaded file. That way, navigating home is easier.

Put the spots you ran across but did not fish or dive into the GPS waypoint memory. That way, when you are in the area, you will see them on the plot screen and may have time to check them out better. Make a hard copy of the stuff you uploaded to the GPS and keep that in a special section of your book. Alternatively, the program allows you to make the GPS display look very much like the printed output. Just make sure that the file version in the GPS is the same as you printed in your book. That way, you synchronize the stuff you upload to the GPS to match your book so that you can scan the book for the points you see on the chart plotter and find out what is near and how good it is.
VI. Menu Reference

1. FILE MENU

These menu selections manipulate the data files.

This command is used to create a new file. Each file can cover a different geographical area so it may have different values for some reference parameters. As a minimum, change the name from "Untitled" to a name of your choice and verify or change the file properties before proceeding. The initial new file properties are taken from the Tools>User Preferences for your convenience. You can change this information now, or do it later using File Properties.

![Creating a New File](image)

The magnetic compass variation is optional and is entered the same way as Longitude with West as positive and East as negative. If used, this will make compass bearings read magnetic instead of true course. With a GPS for course following, most people will not use this. You can get the center Lat/Lon and variation from a NOAA map or from a companion program accessed by pressing "Run MagVar", the magnetic variation program.

**Open File**  **Hot Key: Ctrl-O**

You need to open (load) a file any time you want to work on it or display it. You will get a standard WINDOWS file open dialog box as shown next.
File name displays the name of the file that will be loaded when you select a file and click OK. The box above it will contain the list of files in the folder shown by: Look in.

To navigate through the folder structure, you click on the folder icons in the box or the Look in selection box. To go up one directory level click on the yellow box with the up arrow. For example, to navigate to the C:\LoranGPS folder, you would first click on the C:\ icon in the window to go to the root folder, then using the scroll bar, move down until you see the LoranGPS folder. Double clicking on that folder will open it and show you the files in the window. It only shows files of the type shown in the Files of type selection box.

The Files of type box contains an expansion arrow on the right that, when pressed, drops down a list of file types. You would use it if you are upgrading from the DOS versions of the PROGRAM or want to work on track files. For example, to load a DOS LORAN PROGRAM file, first be sure you have navigated to the right folder. For versions 2.0 to 3.5, you then change the file type to [.DT0] and those types of files will appear in the window. Alternatively, for upgrading convenience, you can upgrade all files at once using the FILE>BACKUP/RESTORE menu choice.

SAVE FILE  Hot Key: Ctrl-S

This saves the file in dBase III format that is the standard file format for the program. The file will be saved in the currently used drive and folder. If you need to verify that you are saving it in the proper place, use the FILE>SAVE FILE AS command.

A note on files on a computer. Files are stored on the hard disk drive as a pattern of magnetic information. When you OPEN a file you make a copy of that file and put it into memory (RAM) to work on. It still exists on the drive in its original form. The program adds waypoints to the disk file at the same time as waypoints are added to the in-memory copy. The program doesn’t, however, modify the disk copy as waypoints are edited or the file is sorted. You must SAVE the file after it has been...
modified if you want the editing changes retained. If you want to discard those changes, just don’t **SAVE** the changed file.

**SAVE FILE AS**

If you want to change the file name or save the file to any drive and folder you choose, use this command. It can be used to make a backup of the file or to save it in another format. When you use **SAVE FILE AS**, you may be asked to confirm the file format to "save as" Data (includes Features files) or Track.

**SAVE AS V5 or V6**

If you want to exchange this file with someone who has an older version of the program, save it with this selection so that the three new fields (Name, Icon, and Depth) are removed to make it compatible. The older program didn't anticipate these fields.

**BACKUP/RESTORE FILES**

This selection allows you to make backups of your files or copy all data and/or map files from one drive or folder to another drive or folder. To use this utility, make sure the source and destination folders are what you want to transfer between, then select one or more files and push the appropriate transfer button shown by the arrows. You can use the shift and Ctrl keys for faster selection.

If you are handling DOS version data files a check box offering to convert them will appear. If it is checked, the files will be converted to DBF files (latest style) during the transfer. Backing up to a CD may require that you format the CD first in windows. Since a CD can hold all the contents of the LoranGPS folder, you might want to just copy the whole folder to the CD using a Windows tool.
Delete A File
Allows you to delete files from the disk one by one, including the one currently open. This will show a standard file selection dialog. Select a file to delete by double clicking on it or select it and push the Open (yes, it's not intuitive) button to delete it and then confirm the deletion.

Find Missing File
Allows you to find files you have misplaced. It will locate and let you open all data files that it finds in the target drive or folder. It will search all sub folders for files with the DBF (or MAP) extension. It may find other program's dBase files too, so it cannot necessarily open all the files it finds. For MAP files, it will direct you to note the file location and open it with MAP>VIEW MAP.

File Properties
Each file has properties such as the inlet and the location of the area center that you entered when you set it up as a new file. This dialog lets you edit those properties. Changing the stuff in: Tools>User Preferences does not effect these properties except when you are exiting that routine and you confirm that you want to change the current file too.

COMBINE FILES
Combines another file with one already opened. The new file will be appended to the end of the open file and the combined file's properties will be set to those of the first file. You will probably want to sort the file and purge or merge duplicates after combining.

SPLIT FILE
You can split files into two parts based on boundaries you set. The boundaries are Lat/Lon, Loran TDs, Range/Bearing, or record numbers.
You specify an area with upper, lower, left and right borders and the program then separates the file into inside and outside (the borders) waypoints. Each (inside or outside) part can be saved on the disk under its own name or discarded. This routine can split overly large files into zone files or break out certain groups of waypoints. The file that is open is left unchanged and remains open.

**SORT FILE**

The file can be sorted by any column of the spreadsheet as shown below.

You have the choice of either using this window or just double clicking on the column header to sort the file. This dialog is a little more complete, however. Ascending sorts put the smallest number at the top of the list. When sorting by double clicking on the header, the second time reverses the sort. Unlike some data base programs, these sorts are permanent, that is, there is no undo.

Sorting on text fields is done alphabetically based on the following precedence of characters:

`!"#$%&'()*+,-./0123456789:;<=>?@abcdefghijklmnopqrstuvwxyz[\]^_`|~`
Note that the first character of the above list is a space. To insure that your sorts perform as expected on a column like the Rating column, you should insure that all numbers are right justified. Ignoring punctuation marks, spaces have the lowest value followed by the numbers, lower case letters and then upper case letters. Thus, if I may use periods to represent spaces, the following are true for text sorting:
.999 is less than 1...
...2 is less than 0001
zulu is less than Able
If two waypoints are alike or equal on the first sort key, the second key is used to break the tie. On numeric fields such as range and bearing, the sort may be done on the full number that has decimal places that are not displayed. Thus, they might look identical, but they are not.
The TAG is the last 4 (user selectable) characters in the description. To return a file to its original order, you might try sorting by Date Code. You can sort a file many ways, but the copy on the disk is unchanged until you save the file. So, to abandon a sorted file you have not saved, just re-open the file on the disk.

Print File     Hot Key:  Ctrl-P
This selection lets you to print the waypoints in spreadsheet form. The printing dialog box gives you a chance to set some basic printing parameters relating to how the material is printed. It also includes a button to select a WINDOWS PRINTER SETUP dialog that allows you to choose which printer to print on. To change what is printed, use PRINTING FORMAT below. Remember, the fields printed and their order follow the Printing Format below and not the display format. This is necessary since you cannot horizontally scroll the printing like you can the display nor is the screen the same size and shape as the page. You can print landscape if you want more data per line.

Printing Format
Here you can specify the fields (columns) to be printed and their order. You can also select standard or bold font, grid lines and Black and White or Colors.

You can select any combination of fields to print. If the Comments field is selected, the printout will take an extra line per waypoint as this field has 90 characters. Some other combinations or a large font will result in two or three line printing, so watch the indicator to see how much of the width of the page is used and how many waypoints per page are possible. Clicking on field names in the left or right box and then pushing the Add or Remove buttons selects fields to print. After the field selection is completed, the program will space out the fields on the paper to even out the white space.

The page margins for printing can be set in this window and they will influence the fit of the fields chosen. If the bottom margin is not big enough, some of the printing may spill over to another page, so if you get two pages for each one you expected, increase the bottom margin value.
You can also choose either the **line spacing** or the **number of waypoints per page**. The program will try to fit as many waypoints on the page as possible given the font size, the line spacing, the orientation, and the field choices. If you do not like the number of waypoints per page it comes up with, you can set it to another number and the program will adjust the **line spacing** to accommodate you. **Bold font** will slightly increase the font size, so you may have to readjust the **number of waypoints per page** after any font changes. You can also select **grid lines** on the paper just like shown on the screen.

The **PRINT PREVIEW** feature allows you to see how the choices you have made effect the look of the printed page. The red borderline you see on the preview shows where the printable edges are. If your text goes over this line, it may be clipped off and not printed. If the text goes over the bottom line, it will cause an extra page to be printed with just a few lines. Note that this line is only an estimate and may not represent exactly what your printer will do, so keep your text away from the red line. Push **CLOSE** to exit **PRINT PREVIEW** and return to the printing setup window. Close this dialog and select **PRINT** when you are ready to print.
Once you have completed optimizing the printing settings, save them by pushing the **SAVE SETTINGS** button. The R/B reference point is not saved with these settings but will not change from what was shown until you change it elsewhere.
Last Three Files Opened
The last three files you opened are displayed near the bottom of the File menu. To reopen any one, click on its file name in this list. The program automatically opens the top one (most recent) whenever it is run. If it can't find that one, it will open a new (empty) file.

Quit, Close  *Hot Key: Ctrl-Q*
Quits the program. If the open file has been added to, combined, or imported, the program may ask if you want to save it.

2. Edit Menu
This menu group performs editing of the file contents. Proficient users learn the standard CUT, COPY and PASTE Hot keys that are common to all WINDOWS applications.

**Cut**  *Hot Key: Ctrl-X*
This will cut and remove a highlighted selection in a spreadsheet cell or entry box. The item cut is placed on the WINDOWS clipboard for pasting in another location if desired.

**Copy**  *Hot Key: Ctrl-C*
This will copy the selected item but not remove it. The copied item is placed on the clipboard to be pasted elsewhere.

**Paste**  *Hot Key: Ctrl-V*
You can paste items from the clipboard into single cells or any entry box.

**Add Waypoints**  *Hot Key: Ctrl-A*
You can start this ADD WAYPOINTS dialog by one of three ways; from the EDIT menu, the hot key, or by just clicking on the spreadsheet below the last waypoint.

If Loran Features have been hidden, the screen will look like:
If you want to suppress loran features or change the way the form behaves, use the **Set Field Preferences** button. This opens the form below for setting the way the name field behaves and allows you to hide or show several of the fields. It also lets you skip over fields that you are not going to enter data into while typing in new waypoints. This is a convenience that allows you to keep your hands on the keyboard and not use the mouse while minimizing keystrokes. Along this line, the program has been designed to allow you to just type away without need to use the mouse except to fix mistakes. The Enter and TAB keys are used to move from one entry box to the next.

### Adding Waypoints to the File

<table>
<thead>
<tr>
<th>Waypoint: 364</th>
<th>Use this form to add new waypoints to the file. Use Set Field Preferences to hide or skip over fields that you do not want to bother with. You can do all entry with the keyboard by using Tab or Enter to move between fields.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latitude</td>
<td>Longitude</td>
</tr>
<tr>
<td>2754.369</td>
<td>8011.450</td>
</tr>
<tr>
<td>Rating</td>
<td>Description</td>
</tr>
<tr>
<td>good</td>
<td>Jim's disaster reef</td>
</tr>
<tr>
<td>Name</td>
<td>Icon</td>
</tr>
<tr>
<td>DISASTER</td>
<td>buoy</td>
</tr>
<tr>
<td>Comments</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Jim dropped everything while diving</td>
</tr>
<tr>
<td>Color:</td>
<td>Symbol:</td>
</tr>
<tr>
<td>cyan, dk</td>
<td></td>
</tr>
</tbody>
</table>

The Enter and TAB keys are used to move from one entry box to the next.
If you have show Loran Features enabled, the Adding Waypoints screen looks like:

You may enter your waypoints into the currently open file as either Loran TDs or Lat/Lon or both by selecting one of the radio buttons at the top of the window. When entering waypoints as both Loran
and Lat/Lon, the program will want to know the source of the Lat/Lon information. Waypoints entered as both are considered calibration waypoints and Loran to Lat/Lon conversions are not done on them. They are used, instead, to derive calibration parameters.

If you enter an out of range number, an alert message shows you what the estimated number at the center of the area would be and asks you to check your entry. Entries that are more than 200 miles or 1000 microseconds (both user definable) from the "area center" are challenged.

The first two entry boxes have titles showing what Loran stations are expected. They are dimmed if Lat/Lon entry is selected. The program has been designed to accommodate many different styles of Loran and Lat/Lon data. If the data can be fit to any of the available Lat/Lon styles or Loran chains, it will be accepted. Common errors such as missing decimal points in the Loran numbers or the wrong chain choice will, in most cases, be rectified automatically. In cases where the number is ambiguous, the program will complain that it can't identify the waypoint. Use the Change Chain button to select the appropriate chain pair if you are entering numbers not the same as shown on the box headers. It brings up the following dialog. You can see, from the display below, what are representative Loran waypoints for each of the chain choices. The chosen chain is shown in the window.

The second and third entry boxes are for Lat/Lon. If you enter numbers in LAT/LON, use one of three forms: degrees and decimal degrees (DD.DDD) or degrees, minutes and decimal minutes (DDMM.MM) or degrees, minutes, seconds and decimal seconds (DDD MM SS.S). Thus 126 degrees, 7 minutes and 30 seconds north is written as either: 126.125, 12607.50, 126 7.50, or 126 7 30.0. South Latitudes and East longitudes are entered as negative numbers. If you want these numbers automatically converted to Loran using the chain shown, check the Convert to Loran checkbox that appears when you have selected Lat/Lon entry. Otherwise, you can convert them later from the menu TOOLS > CONVERT FILE.
The **Rating** is a 4-character field intended to hold information on how good or bad the spot is for fishing or diving, but you can use it for anything you want. The **Description** field is 32 characters and is intended for the waypoint name and description. The **Comments** field is 90 characters for any other comments you may have. It may be used to indicate what dates you visited this spot or how much you caught. The **Name** field is the GPS short name of 6 to 16 characters. These fields sort alphabetically by the rules described under **SORT FILE**. The name will be linked to the waypoint number for any waypoints that you do not enter a name for.

The **Set field preferences** button opens a form for setting the way the fields behave, that is, it allows you to hide or show several of the fields. It also lets you skip over fields that you are not going to enter data into while typing in new waypoints. This is a convenience that allows you to keep your hands on the keyboard and not use the mouse while minimizing keystrokes.

**Color**, **Icon**, and **Symbol** are used for the graphics display and import/export modes and are set with drop-down lists.

The **Color** selections are limited to those in the drop-down list and are carried in the file as the first letter of the color name. Any keyboard character can be used for the **Symbol** in addition to the ones available from the drop-down list. **Symbol** is a holdover from previous versions where the program did not have an **Icon** selection.

The **Datecode** is normally set to the present date. The numerical extension gives you the total number of waypoints entered for that date. You can change the **Datecode** and it will then increment from the new setting as you add waypoints.

You can elect to have a typing **sound** indicating acceptance of each waypoint. This sound tells you where you are when you are not watching the screen. Remember that you can enter multiple waypoints completely from the keyboard (without touching the mouse). Just use the <enter> or <tab> key to move through the fields.

The computer's function keys from **F2** to **F10** can be programmed to hold common phrases or words to use when entering data into the various fields. Pushing the **Program Function Keys** button at the bottom of the window allows you to program them. For example, loran or lat/lon data often has the first several characters the same. They can be programmed on the function keys if you find that handy.

Push **Next Waypoint** to go to the next waypoint or **OK, Done** to exit this routine. The program will save each new waypoint to the disk at this time, so that when you are done or if you suffer a power failure, all the waypoints are safely stored away.

### Delete Waypoints

Select (highlight) the waypoint by clicking on any one of its fields before using this menu item. Alternatively, you can **DELETE** a waypoint by clicking on the waypoint number in the left most column of the spreadsheet. The program always asks you to confirm your deletion, as, once it is done, it cannot be undone except by abandoning this version of the file and reloading the one from the disk. That is, deletions only happen to the copy in memory and not to the one on the hard drives. To save the edited version, you must **save** the file when you are done.
**Find**  *Hot Key: Ctrl-F*

**FIND** locates a match to what you enter in the first box of the dialog shown below. It looks in the field (column) selected by the second box. The search field choices can be a specific column or any column. It will find the first instance of that sequence of characters in the field(s) in the current file. It will then scroll to and show that waypoint highlighted with a yellow background. To continue searching for the next instance, use **FIND NEXT**. The **FIND** routine ignores case unless the **MATCH CASE** checkbox is checked.

![Finding Things in File](image)

**Replace**  *Hot Key: Ctrl-H*

**REPLACE** lets you do a global search-and-replace or individual replaces in almost any field.

![Search and Replace](image)

**Find Next**  *Hot Key: Ctrl-N*

**FIND NEXT** (or Find Again) continues the **FIND** routine or the **FIND DUPLICATES** routine.
Find Duplicates  **Hot Key: Ctrl-U**

This routine finds waypoints that are essentially (but not necessarily exactly) the same. The program looks for duplicate waypoints starting at the beginning of the file. It compares each waypoint to the next 10 waypoints in the TD1, TD2, Lat, and Lon fields. If any waypoints have less than 0.02 minutes difference (user selectable) in both of the Lat/Lon fields, or 0.15 (user selectable) microseconds of difference in both TD fields they will be considered duplicates. The routine will scroll the file to put those waypoints near the middle of the screen and highlight them. You can then edit or delete them. Marking or unmarking a waypoint for deletion only requires clicking on the number of the waypoint in the left hand column. Since the program does not scan the entire file for comparison to any given waypoint, **it is necessary** for you to make sure the file is pre-sorted by either Lat/Lon or Loran TDs. If the program finds any **exact duplicates** during its search, it will delete them automatically. You will see blanked waypoints if this happens. Exact duplicates are alike in every way. To continue searching, use the **FIND NEXT** routine. No marked waypoints are actually deleted until the routine has gone through the whole file and reports no more duplicates found.

To change the duplicates search criterion, go to the **USER PREFERENCES** selection of the **TOOLS** menu and click: **Set Duplicates**.

Find Duplicated Names

Many GPSs will not tolerate duplicated names. This routine will identify which, if any, names are duplicated and let you change them. Names that are linked to the record numbers are inherently not duplicated. If, however, you enter fixed numbers for some names, then there exists the possibility that there will be duplicates that are not noted as such. To avoid this, use numbers that cannot be the same as linked waypoints. One example is that linked names will be passed to the GPS with 4 or more digits like 0001. Therefore, if you want to name a waypoint 001, that is OK.

3. DISPLAY MENU

The selections in this menu control the way the data is displayed on the screen. There are three predefined spreadsheet formats; one user specified spreadsheet format, one basic graphical format and one NOAA chart format. If Loran features are hidden, related formats will be too.

DISPLAY WITH TDs & L/L **Hot Key: Ctrl-T**

This command puts the waypoints on a spreadsheet with columns and rows. This display has the Loran TDs occupying the 2nd and 3rd columns and the Latitude and Longitude occupying the 4th and 5th columns. Normally, the information will extend off the right side of the screen and require horizontal scrolling to see it all. In this display mode, the **Range** and **Bearing** fields are to the extreme right, after **Comments**.

The information on the display can be edited by double clicking on the appropriate cell and doing normal editing. All normal windows type editing can be performed along with cut, copy, and paste. Block selections, however, are not allowed.

The information in your file can be edited using routine WINDOWS editing. As it is set up, all fields on the screen are full of either text or space characters. Editing is done in the insert mode, so you have to delete characters or spaces in order to add new ones. **If it seems like the program is not letting you edit something, try highlighting, deleting or backspacing to remove what's there.**
You can adjust the spreadsheet column widths to hide columns you don’t want to display. To do this, place the cursor in the title row on a vertical column borderline (watch for the cursor to change to a new shape). Then hold down the mouse key and drag the column border to its new position. You can also reorder the columns by dragging the column label to another position with the mouse. These techniques are not permanent, so changing the display mode will reset the fields to their default order and widths. You can, however, capture and use this new column organization by selecting **DISPLAY >SET USER STYLE**.

A horizontal scroll bar is available to see the information that is off the screen. Normally, there is not enough room to display all the fields.

You cannot edit computed information such as **Waypoint Number**, **Range**, and **Bearing**. If you want to edit the Lat/Lon of a waypoint entered as Loran, the program will ask you if you want to make this a calibration waypoint and, if so, where you got the data. See Chapter IV sections 1-3 for more details.

The **chain** column (label Ch) is intended to let you know the origin of the TDs or Lat/Lon. You may have entered a mixture of waypoints in several chains as well as L/L and converted the whole file to another chain. A negative chain number lets you know that the waypoint has been converted and what from. If the chain number is a two-digit number then that waypoint is a calibration waypoint. The first digit indicates the origin or quality of the Lat/Lon and the second indicates the Loran chain.

The **Color** column (label Cl) contains a single letter that is the first character of the color name. Colors are light and dark: Red, Green, Blue, Yellow, Cyan, Magenta, Orange, Gray, and, of course, black.
To change a Symbol (in the Symbol column) (label Sy) to a character that is not one of the keyboard characters, you can paste one from another waypoint or from the Windows' CHARACTER MAP in the ACCESSORIES group of START>PROGRAMS. Use the SYSTEM font selection and copy the appropriate symbol. Keep in mind the global search and replace function for wholesale changes. The Symbol column is a hold over from earlier versions that did not have an Icon column.

**Display with TDs & R/B**  *Hot Key: Ctrl-R*
This display style has Range and Bearing to the Inlet reference point occupying the 4th and 5th columns. See also, SET R/B REFERENCE and NUMBER FORMATS.

**Display with L/L & R/B**  *Hot Key: Ctrl-L*
This display style has Latitude and Longitude occupying the 2nd and 3rd columns and has Range and Bearing to the Inlet reference point occupying the 4th and 5th columns. Loran information is displayed in the last few columns. The chain number lets you know whether the data was originally Loran TDs or Lat/Lon.

**Display with User Style**
If you have set a user style with DISPLAY> SET USER STYLE, this command uses that display form.

**Set User Style**
This command allows you to capture a display style you have created by column moving and re-sizing. You rearrange the columns and set the column widths to your liking. Click on the column header and drag it to another position to re-order columns. Click on the column separator and drag it to resize the column width. When you are satisfied, use this selection to capture your preferred style for use with the DISPLAY WITH USER STYLE command. This style will be saved with your USER PREFERENCES.

**Display on (Simple) Chart**  *Hot Key: Ctrl-G*
This command displays a simple chart of the waypoints on the screen. For the purposes of the program, a simple chart is defined as an ad-hoc graphical representation of the file area as opposed to a NOAA chart. The simple chart starts with a blank sheet to which are added layers that may have Lat/Lon lines, Loran lines, waypoints, a coastline, etc. You select the layers with CHART OPERATIONS> CHARTING OPTIONS. The program first tries fitting all the waypoints in the file on the screen. This can sometimes backfire if one of your points is in Timbuktu. Once you have made sure that all your points are in the same region, it should give you a good chart. The simple chart shows an uncluttered view of your data. Contrasted to that is the NOAA chart that uses a digitized official NOAA chart. NOAA charts cannot be zoomed or panned infinitely like the simple charts can, and are cluttered with data that may obscure your waypoints. Bathymetric charts are even more cluttered.
When displaying a chart, the **Chart Operations** menu is enabled and you can pick operations from it. You can also use the right mouse button to bring up this menu. Panning can be done by using the cursor control keys or by **Select a new chart center**. You can also use **Center the chart on a waypoint** to pan the map to show or find a particular waypoint.

Zooming in or out by factors of 2 or 5 can be done with the **Zoom** command or by using the hot keys F3 to F6. See the **Chart Operations>Zoom** sub section for more details.

Coastlines are contained in files on the hard disk. To show a coastline on the chart, select **Coastline** from the **Chart Operations** menu and select one of the choices presented. Picking a higher resolution than needed will slow down plotting, so as the program zooms out, it will pick lower resolution coastlines as appropriate. Selecting **Coastline>Remove** will remove the coastline.

To control how the chart is displayed see **Charting Options** in the **Chart Operations** menu. This allows you to select or deselect layers of the chart.

**Display on NOAA chart**

The types of charts that may be displayed with this selection are the BSB/KAP or NOS/GEO formats from the National Ocean Service. These may be obtained from the Andren Software Co. or from the free NOAA site: [http://www.nauticalcharts.noaa.gov/mcd/Raster/index.htm](http://www.nauticalcharts.noaa.gov/mcd/Raster/index.htm) and a selection is normally shipped on the distribution disk. The first window is for chart selection assuming you have some
charts to display. If you know that you have added charts and they do not show, then push the **Rebuild Catalog** button.

You can sort this display by single clicking on a column header. Columns accessed by scrolling to the right contain the chart upper left and lower right Lat/Lon for reference. This allows you to find a chart based on the area it covers instead of just using the name or number.

The old Maptech supplied the utility used to display the NOAA charts to the Andren Software Co. with the understanding that no support would accompany it. It has a few quirks that have been worked around, but one that remains is that the charts will not open if the path to the charts has a space. That is, a path such as: C:\Program Files\LoranGPS\11474.kap will not work. If such a path is chosen, the program will inform you of the problem and abort. The charts do not need to be in the LoranGPS folder, so you can make a chart folder as long as the path does not contain a space.

Once a chart is chosen either by double clicking on it or by selecting it and pressing OPEN CHART, a new window displays the chart. This charting capability follows many of the characteristics of the simple charting capability but is constrained to certain zoom levels and a given graphical area. Nonetheless, the program can add features selectively to the chart such as additional Lat/Lon lines or Loran lines and, of course, your waypoints.
The chart displaying utility has another quirk in that if landscape orientation is chosen for printing by
the program, it will not do it. However, if the printer is set to landscape directly, it will.

**SET R/B REFERENCE**
This choice will allow you to temporarily change the Range/Bearing reference point. To permanently
change the R/B reference point for the file use FILE PROPERTIES instead. This command opens
a dialog that lets you specify a reference point in one of four ways. It can be any Lat/Lon or TDs you
enter, or any waypoint from the file, or from a list of stored reference points. If you enter a new
reference point, you can put it into the list of reference points that can later be selected from the drop
down list as shown below.
Number Formats
Here, you specify the program's numbering format, the number of decimal places, and the use of leading zeros. This window has tabs for the Lat/Lon, Loran TDs, range and bearing formats. An example is shown on the bottom of each window to show how you what you have chosen will look.

This window also allows you to set the warning limits for data entry. These alert you when the number entered during **ADDING WAYPOINTS** is not within a reasonable range.

You can also set the range to be kilometers, nautical miles, or statute miles.
4. Map Menu

In the program we define a map as a specific chart area to print that you save on the disk and can recall by name. We define a chart as an ad-hoc graphical display that is created as needed but is not named or saved (with the exception of the NOAA charts). This menu group allows you to define an area and create a MAP that you can view, print and save. You may want to make a series of MAPs that cover your operating area that you will print each time you re-do your book.

Create/Modify Map

This command will allow you to create or modify a MAP. You fill in or modify the name and three borders of the MAP. The program will fill in the fourth border for you to insure that the MAP will fit the paper in the orientation you chose. You can also specify a coastline and/or a Features (points of interest) file that will be linked to the MAP when it is viewed or printed. See chapter IV.3 for more information on scaling and sizing MAPs.
Once the MAP parameters have been specified, push **OK MAKE MAP** and the MAP will be stored in a MAP file along with the borders and associated COASTLINE and FEATURES file names. Even if you do not intend to use Loran lines, they are created in case they may be needed.

Unless Loran features have been hidden, the window will display the program's choice of Loran line spacing and the number of Loran TD lines that will appear on the MAP for each station of the chain pair. If you do not like the spacing the program selected, you can change it. You can enter line spacing from 0.1 to more than 1000 microseconds as long as this doesn't cause the number of lines printed on the MAP to exceed 35 for either TD. If you are not going to use Loran lines, this selection is of no consequence.

**Note:** A possibly easier way to create a MAP is by using: **Chart Operations > Make A Map From This Chart.** This MAP will be the size of the area that was displayed but scaled to fit the page. If you adjust the borders, it will recalculate the right border longitude.

**View Map**

This command will allow you to display a MAP on the screen along with the waypoints from the open file to verify that it is correct before printing it. The display shows that the MAP has boundaries and a Loran grid scaled for the MAP. You can pan and zoom this display, but the MAP will always print just what is shown inside the borders.
Since you can pan and zoom this display, you can see the size and extent of the Loran lines grid (if used) that is saved with the MAP. The area that will be printed is bordered in dark lines. You can also see if you have some waypoints that missed falling in the printed area.

**Show All Maps**
This selection allows you to show all your MAPs on the screen as outlines with names to see if you have missed any areas or to find the name of the MAP that covers a specific area. Once enabled, it also works when printing a chart. It has three sub selections for 1. showing from a list, 2. all MAPs in the folder, or 3. all NOAA charts in the folder. All MAP files in the selected list or working folder will be displayed on the chart if possible.

**Delete a Map**
Deletes selected MAPs one by one.

**Print Map**
You can select one or more MAPs to print with this command. The MAP will be combined with the currently open waypoints file to make the printed MAP. MAPs are created with either portrait or landscape printing and will print that way.

You can select multiple MAPs by holding down the Ctrl key while clicking on the MAP names to print (a standard WINDOWS technique). To select a block of MAP names, hold down the Shift key and click on the first and last MAP names to include in the block.

When you print MAPs, they are also displayed on the screen to verify what is being printed.
**BATCH PRINT MAPS**

You can create and select lists of MAPs to batch print. A MAP list may, for example, be created for each waypoints file. This way, you can print all the MAPs that correspond to that file using one command. Use the CREATE BATCH LIST routine as in the following example:

![Batch Print Maps](image)

**MAPPING OPTIONS**

There are several options for printing the MAP such as font size and the use of Lat/Lon lines, Loran lines, or Range/Bearing lines. The **Mapping Options** window is shown below.

![Mapping Options](image)

The waypoints can be displayed as numbers, names, symbols or dots. The numbers are the list numbers in the waypoint file and the symbols are the symbols entered in the waypoints' Symbol field.
If no symbol is entered for a waypoint, the list number is used instead when plotting symbols. The Name is the GPS short name and asterisks are used for the dots.

The Lat/Lon line spacing is specified in minutes. If the spacing is too large or small due to zooming, they are re-spaced. Range and bearing lines can also be placed on the chart. They are relative to the R/B reference point shown in the bottom of the selection window. The bearing lines radiate out from the reference point and the range lines encircle it. You can also specify that a list of the waypoints associated with (falling within the borders of) this MAP be printed on a separate page after a MAP is printed.

These settings (except for R/B reference) can be saved. This dialog also allows setting the page margins. It’s a good idea to set these before creating MAPs so the computer will know what area is available for printing.

Colors for the lines on the CHART or MAP can be selected by pushing the CHOOSE COLORS button. On the color selection window, click on the line type or feature you want changed and select a color from the palette.

Since some laptop monitors do not show the colored lines well in bright sunlight, you can also deselect displaying colors. This will display all colors as Black including the colored lines. Additionally, some printers do not show the colored lines dark enough in the B&W mode, so you can deselect printing colors on the Printing Setup form. This will print all colors as Black on White.

5. Chart Operations Menu

In this program, charts are defined as graphical displays with lines and waypoints on them that are created and displayed temporarily. These are different from MAPs, which are based on a predefined area and are stored on the disk. This menu column deals with both charts and MAPs. It is dimmed unless you are in DISPLAY CHART or VIEW MAP modes. When in this mode, the viewpoint can be panned (left/right, up/down) with the cursor control keys. For more precise panning control, use some of the other CHART OPERATIONS routines like SELECT AREA.

Chart Whole File (Reset)
When the DISPLAY CHART mode is first selected, the chart is scaled to fit all of the waypoints on the screen. After extensive zooming and panning, you may get lost and want to start over, so use this to restart. If the file contains some points far removed from the rest, the chart will show a very large area. Points with 0.00 Lat/Lon are not included on the chart.

Center Chart on A Waypoint
This command will allow you to specify the waypoint to center the chart around. It is especially useful if you have panned and zoomed and lost track of a waypoint you wanted to see.
Select New Chart Center
This command will allow you to click on a spot on the chart to make it the new center. The cursor will change to crossed arrows to let you know it is in this mode.

Select Area (To Expand)
If you want to expand a portion of the screen to fill the whole screen, you can use this command. In this mode, you get a diagonal double headed arrow. Depress the mouse button on one corner of the area and drag open a 'rubber band' enclosing the area. When you release the mouse button, the area chosen will be expanded to fill the screen. The 'rubber band' has the same width/height ratio as the screen.

Zoom 2X, 1/2X, 5X, 1/5X  Hot Keys: F3, F4, F5, F6
These functions allow you to zoom in and out in ratios of 2 or 5.

Identify Waypoint (On Chart)
The Identify Waypoint command will print the description of a waypoint on the bottom line of the display with Loran or Lat/Lon depending on your display mode. You click on (or near) a waypoint on the screen. The cursor will change to cross hairs to let you know it is in this mode. Click on the upper left corner of the bounding rectangle of the waypoint name.

CREATE A MAP FROM THIS CHART
An easy way to make a MAP of a certain area is to zoom and pan the chart display until the waypoints you want are displayed on the screen. Then you use this command to make a MAP for that area. The CREATE MAP window will open with the MAP borders already determined. After the MAP is made, you are returned to the chart screen. To view the MAP you created, select VIEW MAP. Keep in mind that, in portrait print mode, the paper is taller than the screen for the same width. The MAP area will therefore include some waypoints that were above and below the screen. Landscape orientation will better match the typical screen display in area.

Print This Chart
This command prints what you see on the screen but the area printed may be taller than the area displayed because of the different shapes of the paper and screen. The printout will be titled: “Instant Plot”.

Coastline
Coastlines, once added, will be put on all charts until canceled by REMOVE. The coastline files are organized as US only or World Wide in two resolutions each. If you are plotting outside the US, you will need to use the world coastlines and if in the US you can use either. The resolution of the US only coastlines are higher than the world coastlines. If showing a large area, plotting the highest resolution would slow the screen refresh. Therefore, the program will automatically reduce the resolution if you zoom way out.

In order for the coastlines to plot, the coastline files must be in the LoranGPS folder. They are the four files with .CS4 extensions.
FEATURES (Add Features)

This file type could be called Points Of Interest (POI) and is intended to mark your maps and charts with names of points you want on most maps. Note: With the inclusion of the new Name field, a Features file becomes less necessary. I create names for some of my waypoints and leave the rest linked to the row number. However, you can create a Features file that works for several files. If you want to identify features or POI such as reefs, wrecks, buoys, and inlets with symbols or names, you can create a Features file and use it with all your MAPs and charts. A Features file is formatted like a regular waypoint file but with special characteristics. For each waypoint in this file you enter a symbol or a name (in the Description field). To remove or disable Features from your charts, choose REMOVE. A Features file can be used in conjunction with any waypoint file.

To put one of the symbols on a chart or MAP, you put the ASCII value of the symbol in the RATING field of the Features file. The various symbols that can be put on the MAP and their ASCII (or ANSI) value are shown in the CHARACTER MAP that is a WINDOWS accessory. Be sure to use System as the font for this function. Do not use the characters from 0 to 32 as they are reserved for commands instead of characters. To put labels on the MAP, you leave the RATING field blank and put the labels you want in the DESCRIPTION field. One features file should suffice for all your MAPs, but you can have as many as you like. The features are displayed on the MAP with the upper left-hand corner at the point determined by its Lat/Lon. This may place it over a similar waypoint in the waypoint file.

TRACKFILE (Add Tracks)

Tracks are linked points that show the trail of your travels like cookie crumbs. This command will display a list of saved TRACK files for you to choose from. The TRACK file chosen will be put on all charts from then on. To disable or remove TRACKS, choose REMOVE. A track file has the extension .DBT.

A TRACK file has only three fields (Latitude, Longitude, and Rating containing the words: STRT/STOP) and can alternatively be opened and displayed on the spreadsheet for editing if desired. You can make a track file out of any waypoint file if desired by File>Save-File-As and setting Save as Type to Track file. For example, you can make a file of a day’s fishing (possibly from your sonar log) and then save that as a track file. That will allow you to plot a line between the points you visited in the order you visited them. Another use is to outline restricted areas like the Oculina Bank. One more point is needed than the number of corners in the figure. For example, a square needs 5 points, as the stop point is the same as the start point. Setting the start of a line by typing STRT in the Rating field and indicating the last point in a line with STOP in the Rating field delineates multiple tracks. Therefore, you can use the TRACKS capability to put various line drawings on the graphical display by creating pseudo Track files.

Track Plotting

Introduction
This feature uses your GPS or Loran to supply your present position to the program for track plotting. It uses the NMEA-183 serial interface that is available with most Loran and GPS receivers and
connects to the computer with a cable that you supply. Check your equipment manual for the proper connections. The cable should be connected to one of the COM ports on your PC (see below).

Choosing **TRACK PLOTTING** opens the Track Plotting control panel.

---

**Data Connection**

Your first choice is which computer data COM port to use. When you push the **SET Com Port** button, the following window is shown. Select the COM port you think the cable is connected to. On an older desktop PC, the mouse may be connected to COM 1 and DATA/FAX modems can take COM 4. Start with COM 1 and try others if that doesn't work. The other COM port parameters can be set to NMEA standards or to custom settings if your GPS is not standard. If you have no serial port on your computer, you will need a serial to USB converter device.

Once communications is established with your GPS or Loran, you will see the NMEA sentence traffic in the **COMMUNICATIONS TEST** window within the **TRACK PLOTTING** window. The sentences that start with either $LCGGLL, $GPGLL, $LCRMC, or $GPRMC will be the ones used for plotting. The GPS or Loran usually outputs these sentences once per second. You may need to set your Loran or GPS into the right mode to output the NMEA-183 sentences. Check its manual for how to do this. If your GPS or Loran gives you a choice of NMEA 183-1.5 or 2.0, use the 2.0 as this will give you more digits of precision.
Hardware Connections

There are two types of connectors used on the PC. The old style is 9 pin serial and the newer one is USB. Look at the back of the computer to see which is available. If you do not have a serial port but instead have USB ports, you need a serial to USB converter. You cannot just connect the serial wires to a USB connector; the protocols are very different. If your GPS does not have an NMEA-183 output, then you may not be able to use this feature. If your GPS has a USB output and you connect that to the USB port of the PC, that will probably not work as the program looks for a serial port.

The pin connections for the PC end of the cable are:
- **Function**: DB-9 pin
- **Data**: 3
- **Ground**: 5

The pin connections for the Loran or GPS end of the cable can generally be found in the manual for that equipment.

Operation

You can choose to plot points at intervals of 1 second to 300 seconds or at distance intervals of 60 feet to 10 miles. In the latter mode, a new position is plotted only if you get more than this distance from the last point plotted. The track plot length (memory) can be set from 10 to 30000 points and letting it wrap around when filled can reuse the track memory. While the track is being plotted, the Lat/Lon and the width of the display in miles are displayed on the top of the screen. If the GPS or Loran has not found or loses the signals and has no data, this display area will say "no Lat/Lon available".

The track style can be a series of dots, dots with a line connecting the dots, a line only, or no track, just the present position symbol.

You can select FOLLOW BOAT where a symbol representing the boat's position is centered in the graphic screen. The screen is re-centered on your present position if the track gets more than 10%
away from the center. If you want to view some other area, turn off following, then pan and zoom as needed. All normal graphics features are available while plotting. You will normally want to zoom in from the original display setting to show the track in more detail.

You can revisit the **TRACK PLOTTING** control panel while plotting without disturbing the plotting process. Certain operations, however, will interrupt plotting momentarily. The file opening dialog box, for example, will divert the computers' attention from plotting. Screen savers can also suspend program operation and thus plotting. There may be up to 3 seconds of delay in resuming plotting if it is interrupted. To erase the present plot and begin anew, push **START NEW PLOT**.

While in the track plotting mode, the **IDENTIFY WAYPOINT** function will not only identify any waypoint on the screen, it will also calculate your range and bearing to it. The program will find the nearest waypoint to the spot you clicked on and give you the range and bearing from your present position to it.

You can save the track to a file if desired. It will be put into a track file (*.DBT) that can be later examined, edited, or presented as points or as a track. To display a saved track, select **TRACKS** from the **CHART OPERATIONS** menu.

You can save the present boat position by pushing the **SAVE THIS SPOT** button on the **TRACK PLOTTING** Control Panel. This will show the **ADDING WAYPOINTS** dialog and allow you to name the spot and give more details if desired. This waypoint is then added to the file being displayed. Push **OK, DONE** to finish to return to plotting.

---

**Charting Options**

Sets some optional parameters for Charts and MAPs. It allows you to specify the font size, the Loran or Lat/Lon line presence and spacing and a choice of range and bearing lines. Changing chart settings may change the corresponding MAP settings. That is, Charting options and Mapping options are somewhat linked.
If you select **DISPLAY LORAN LINES**, two more choices become visible, **LABEL LORAN LINES** and the **CHAIN** that will be displayed. You can change the chain choice by pushing the **SET CHAIN** button and the chart will then be re-displayed in the new chain. When zooming out you will eventually get to the point where the lines are not completely displayed due to limitations in the algorithm and the geometry of the Loran lines. When displaying Loran lines, the display may slow down because of the computations for the lines. Turn off Loran lines and range/bearing lines if you need to speed up panning and zooming.

Colors for the lines on the CHART or MAP can be selected by pushing the **CHOOSE COLORS** button. On the color selection window, click on the line type or feature you want changed and select from the palette.

Since some laptops do not show the colored lines well in bright light, you can de-select colors. This will display all colors as black. Additionally, some B&W printers do not show the colored lines dark enough, so you can de-select colors for printing. Finally, for night viewing, you can invert the colors to show white on black.

### 6. Tools Menu

**User Preferences**

The **USER PREFERENCES** screen under the **TOOLS** menu personalizes the program with information about the areas that you fish. Each user of the program will need to set up defaults for...
some important parameters with this screen. See the introductory information in chapter II section 2 for initial settings. The program is shipped with sample information an area thought to be in the part of the USA that the buyer resides. Enter your personal information in place of this sample where appropriate. Some of this information is used for initializing new files and the rest applies to general program operations.

The program is shipped with sample information an area thought to be in the part of the USA that the buyer resides. Enter your personal information in place of this sample where appropriate. Some of this information is used for initializing new files and the rest applies to general program operations.

One of the main settings in User Preferences is the center Lat/Lon and Loran chains. Even if you do not expect to use Loran, it is better to set it up in case you get a list of data from someone that is in Loran. However, you can set Hide all Loran features and not be bothered with them. The setting of a center Lat/Lon gives the program a general idea as to where your fishing area is. From that, it can make up representative Loran waypoints to check your data entries against and to help find the appropriate Loran chains to use.

You can enter Lat/Lon numbers in any one of four distinct forms. Use positive numbers for N and W and negative for S and E. For example, the following are all equivalent and valid:

- 28.9873 degrees
- 2859.238  or:  28 59.238 degrees, minutes
- 28 59 14.28 degrees, minutes, seconds

If it bothers you that there are many ways to express Latitude and Longitude, think of the many ways we express time. Half past ten, ten thirty, 30 minutes 'til eleven, 3 minutes and 2 seconds after midnight, and so on. With the exception of the 12/24 hours versus 90/180 degrees, converting the numbers between versions is the same.

You can use dashes in place of the spaces if you wish. If the program sees a number with two spaces or dashes it will assume that it is the last type. A number with one space or a number that exceeds 60 will be interpreted to be the second row form. A common mistake is to leave out the periods, which are not prominent on the GPS's display. Unfortunately, you cannot do that here. So, if you put in a number like: 28 59 238, the program will complain that there are more than 60 seconds in the number. Did you mean 59.238 minutes or did you mean 59 minutes and 238 seconds? It might, however, accept 28 59 001 as valid when it is not, so use the accepted forms.
The most common form of GPS display is the second one on the second row (28 59.238) and this one has a period. I like the first one on the second row since it is more compact.

Previously, in chapter III, you should have set the Printout HEADER, Center Lat/Lon and Inlet Name and Lat/Lon. Some of the options not covered there are

**Set Number Formats**

See Display>Number Formats

**Set Duplicates**

The duplicates searching routines can be programmed here. Duplicate searching is done on a sorted file since, for speed, the routine only checks the nearest 10 waypoints in the list for duplicates. You can also set what is considered an exact duplicate for automatic deletion.

![Duplicates search and purge criteria setting](image)

**Restore Settings**

If your User Preferences data gets corrupted, you can restore the original copy that came with the program from the CD. Push this button and navigate to the appropriate drive where this information is held.

This routine is also useful if a form disappears or cannot be accessed due to being moved off screen too far to grab. This happens sometimes if dual monitors are used and then one monitor is removed. In this case, the form locations can be on the missing monitor. This routine removes all saved form information in the Windows "Registry" and starts with all forms centered on the main screen. If this was the case, you do not need to reload the original settings, just select **RESTORE SETTINGS** and then cancel out. Then exit the program and start over.

**Select Loran Chains**
The Loran chain pairs are used by the program to perform all calculations involving Loran. If you reside in SE USA, an example of custom Loran chain numbers for central West Coast Florida is initially installed when you get the program. If you are not using obsolete Loran chains or you have no intention of ever using Loran, you should be able to leave this selection as is. If not, select the chain pairs you need by pushing the Select Chains Button. This brings up the **Chain Selection** dialog box shown later.

There are 23 Loran C systems active or discontinued, and there were 64 Loran A systems that are available in the chain file. In addition, the Department of Homeland Security, in its infinite wisdom, has made changes to the timing of the 9960 and 8970 chains such that it is important to know if your data is before 1/17/07 or after. Two sets of station information are available for these two chains and the user has to keep in mind which one he needs for what numbers. If you are faced with this situation, do a custom chain selection and make the first instance of 9960XY be the before 1/17/07 and the second one be after. I have made the program show which is which but you need to keep track. Additionally, there is currently only one set of ASF carried for each of the 9960 and 8970 chains, so, if you calibrate conversions, it is best to do it with all before or all after data.

For the USA, the Loran system covers most of North America as shown below. Loran chains are represented by the Group Repetition Interval (GRI). This represents the period between radio pulse groups sent by the master and slave stations in the chain. For example, the 7980 chain covers the Southeast. This chain radiates pulses every 79,800 microseconds.
LORAN-C COVERAGE GUIDE

Anomalies do exist in certain areas regarding the selection of a pair of stations. Local knowledge may suggest that a pair, other than those indicated below, are the stronger pair.

THE GREAT LAKES

The 9960 chain gives the best coverage in Lake Ontario and in Lake Erie. 9960W and 9960Z is the preferred pair in Lake Ontario. 9960Y and 9960Z is the preferred pair in Lake Erie. 8970X and 8970Y is the only reliable pair for Lake Superior and Lake Michigan. Lake Huron falls in the coverage area of both the Great Lakes Chain (8970) and the Northeast Chain (9960). 8970X and 8970Y is the preferred pair but the 9960W and 9960Y pair also provides strong coverage in the southern part of the lake.

THE NORTHEAST COAST

The preferred coastal LORAN-C pair from the Canadian Border to Nantucket Island is 9960W and 9960X, close to shore. 9960W and 9960Y give reliable coverage further off-shore.

THE MID-ATLANTIC COAST

From Nantucket to Cape Hatteras, NC, the preferred pair is 9960X and 9960Y.

THE SOUTHEAST COAST

From Cape Hatteras to Fort Lauderdale, Fla. the preferred pair is 7980Y and 7980Z. There is some overlapping coverage between the Northeast chain (9960) and the Southeast Chain (7980). South of Cape Fear, N.C. to Brunswick, Georgia, 9960X and 9960Y can be used offshore. Closer inshore from Cape Fear to St. Catherine's Island, GA., 9960Y and 9960Z is the preferred pair.

SOUTH FLORIDA AND THE GULF COAST

From Fort Lauderdale around to Cape Sable the preferred pair is 7980W and 7980Z. 7980W and 7980Y provide the most reliable coverage along the entire west coast of Florida from Cape Sable to Panama City. From Panama City to Mobile, Alabama, the preferred pair is 7980X and 7980Y. In the western Gulf of Mexico from Mobile to Grangeville, Louisiana, the preferred pairs are 7980W and 7980X. From Grangeville to Brownsville Texas, the preferred pair is 9610Y and 9610Z.

THE WEST COAST

5990Y and 5990Z is the preferred pair from the Canadian Border along the Washington State Coast down to about 44 degrees latitude (along the Northern Coast of Oregon). 5990X and 5990Z provide a strong fix further off the Washington and Oregon Coast. Off the southern portion of the Oregon Coast and the extreme northern portion of the California coastline, 9940W and 9940X provide the best intersections. 9940W and 9940Y are the preferred pair along the northern California Coast to just below San Francisco. 9940X and 9940Y is the best pair off the coast of southern California.

OBSOLETE CHAINS

If you have really old data, it is possible that the waypoints are from a now obsolete chain. For example, from 1966 to 1978, the East and South East US was covered by the 9930 chain. Data on this
chain is available in the program and it can be converted to Lat/Lon. Some other obsolete loran C chains are lost in antiquity and insufficient data is available for them.

You only need a small subset of the Loran station data to use. Most users need only one station chain (pair) and some need several. You can choose up to 8 chains to work with at any one time. If you are only using GPS, you might select some Loran chains anyway, as you may need them sooner or later. For example, many users get lists of Loran waypoints from friends or off the Internet. If you are unsure as to which Loran chain pairs to use, push Suggest and the program will suggest some for you based on your center Lat/Lon. Alternatively, you can ask someone more familiar with Loran, check the graphics on our web site, or call us.

If you are not planning to use obsolete Loran chains or more than one Loran system, you can use just the suggested chain choices. If you choose Suggest, you will be presented with the closest Loran system and asked to approve it. A system is for example: “9940, US West coast”. Loran station systems are also referred to by their Group Repetition Intervals (or GRIs) such as 9940. If the suggested choice is not the one you want, push NO and the routine will pick the next nearest system. If all suggested choices are wrong, you probably have the wrong center Lat/Lon. If all else fails or you need special combinations, you will need to do custom chain selection. Special combinations occur if you are in an area served by two Loran chains such as in North Carolina. The Cape Fear loran station serves both 7980 and 9960 systems.

To do custom chain selection, you need to know something about Loran. The Loran C system designates master/slave station sets by the names: Whiskey, X-ray, Yankee, and Zulu (and occasionally Victor). These are abbreviated to just the first letter. Each master/slave set gives you one Loran number and you need a pair of Loran numbers to navigate by. We will call such a pair of numbers a chain. For custom Loran C chain selection click on the check boxes of a pair (2) of master/slave sets (V, W, X, Y, or Z) and then push **OK, Next Pair**. You can select up to 8 chains that will be numbered from 1 to 8. Chains #0 and #9 are pre-assigned to represent Lat/Lon.
If you are not familiar with Loran chain designations, look at the cover of the manual. Consider line 14160. It is the 7980W line. Likewise, line 44600 is the 7980Y line. Therefore to use the 14160/44600 numbers, you would choose the 7980W/7980Y pair which is chain #2 in the setups shown here.

**Loran A coverage**

If you have old lists of waypoints that use the Loran A chains, you need to pick the appropriate A station pairs from the next screen that is shown by pushing the 'Loran A Chains' button.

While selecting Loran A pairs, you check two station sets rather than two master/slave sets. While the Loran A chains have been out of service for many years, you will still find some fishermen hanging on to their old books of numbers. Loran A chains only gave 1000 ft. or so of accuracy and converting them does not improve on that accuracy. Nonetheless, these waypoints are a potentially useful source of information on reef and wreck locations. Selecting the right Loran A stations can be a challenge in many locations if you have no clue as to what are the right ones. The author normally sets up what might be the right stations based on the station locations and then checks the typical numbers on the User Preferences spreadsheet. This shows what the Loran A waypoints will be at the center Lat/Lon. If this comes close to any of the displayed choices, then that station is probably right. Alternatively, once the chains and stations are chosen, you can plot a file with Loran C waypoints in the right area and select Loran lines in one of the Loran A chains. This will show how those lines run and may give you a better idea. The graphic below shows the Loran A station coverage areas.
Loran A used two station pairs to get a fix. For example, for Tampa on the West coast of Florida, the typical pick was 3H0 and 3H1.

**Set conversion method**

The conversion process from Loran to GPS uses complex mathematical formulas that require correction factors called Additional Secondary Factors (ASFs) to achieve acceptable accuracy. These may be applied in the conversion process by one of three methods:

- Use ASF values out of user calibrated government tables
- Use uncalibrated ASF values out of the government tables
- Use single set of ASF values per file rather than a table

See chapter V sections 1 and 2 for more information on what these mean.
The Perform Calibration Now selection on the Set Conversion Method dialog is to be used later, when you have a file with calibration waypoints and want to calibrate the conversion process or calculate ASFs.

Set ASFs: This button only shows if you are using a single set of ASFs per file (choice 3 in the Conversion Methods selection). ASFs are Additional Secondary Factors that are used in conversions to compensate for the fact that land features such as buildings, mountains, swamps, lakes, deserts, and such will distort the Loran signals as they travel to you. This distortion can be as much as ±5 microseconds but is generally very stable. It can cause the Loran to Lat/Lon conversions to be less accurate than they should be. Using ASFs will correct for the distortion and restore the accuracy. You have two options for setting ASFs. Push the Set ASFs button and, if you know your ASFs, enter them in the appropriate boxes, otherwise set them to the Defense Mapping Agency (DMA) suggested values that show up in the window. These can be changed later, as better data becomes available.

In this window you have the option of setting the current file’s (assuming one is open) ASFs to the Default or DMA values too.
Calibrate Conversions

This procedure first determines which calibrations style best suits you. The choices are:

Use the government tables calibrated with your calibration waypoints.

Use the government DMA tables as-is to perform the conversions.

Use a single set of ASF values for all waypoints in the file based on either an entered value or the average of the calibration waypoints.

See chapter V section 1 and 2 for details on how to chose the best method for you. Initially, chose method 2 to get started. Several areas have already been calibrated, so the user-calibrated tables are the best choice. For those areas that are not pre-calibrated, choices 1 and 2 are equivalent until you have performed a calibration.

If you have chosen either method 1 or 3, and have entered all your calibration waypoints, push the Perform Calibration Now Button. In the process of calibrating the conversions, a file is created that contains all the calibration waypoints. It is called Calib–ASF.dbf and will contain all the calibration waypoints of all the files you have calibrated with. Therefore, the program will apply calibration waypoints from one file to another if they are in the vicinity. You can chose to begin anew by erasing the old calibration file while calibrating if you believe that it has been contaminated with questionable data. Once the calibration routine is finished, it will recalculate all the conversions in the file. A report on the calibration results is then generated. This report can supply valuable information on the quality of your data. You might find, for example, that all the calibration waypoints taken on a particular day are suspiciously inaccurate indicating a hardware problem on that day.

The Calibration selection screen additionally allows you to examine the ASFs of both the government and user adjusted tables for your area. This will better inform you as to the ASF values.
that will be used and to give you a feel for the variability of the values over your area. In some areas, the ASF values are very uniform across the area and a single value (method 3) will be a good choice. In other areas, the ASF values vary widely from place to place and you will be better off using the user-calibrated tables (method 2). The example below shows one such area where the values are not uniformly distributed. The tables are in 5-minute increments that equate to about 5 nautical miles. This table shows a jump from 1.9 to 2.3 microseconds in 5 miles. That’s a potential error of around 200-ft.

### Recalculate L/L
If you change the center Lat/Lon or the ASF factors in a file or import a file from some source where you are unsure of the conversion accuracy of Loran to Lat/Lon use this routine. It will go through the file and recalculate the Lat/Lon of all Loran waypoints (except those entered as Lat/Lon) using the current ASFs.

### Convert File
This is the routine to convert Lat/Lon waypoints to Loran if they are not already converted. It can also convert a file with a combination of different Loran chains to all have the same Loran chain. A minus sign will be appended to the chain number of the converted waypoints to show you which ones were converted and what they were converted from. Waypoints already in the desired chain and calibration points will not be affected. The conversion process overwrites the original TDs so save the converted file under another name to avoid losing the original data. You might need them later if you change the ASFs (or calibrate) and do a more accurate conversion.

### Re Sequence Date Code
Imported files are dated the day they were imported, and you may want a different date. This routine takes the DATE CODE of the first waypoint as a reference and re-sequences (changes) all the rest to be in numerical sequence. If there are more than 999 waypoints in the file, it will increment the date as necessary.
**Uploading and Downloading using a cable**

A limited selection of upload/download capabilities is incorporated into the program. It handles many older Lowrance, Eagle, Garmin, NorthStar, or Magellan GPSs.

**Lowrance/Eagle**

There are two basic ways to transfer data to and from most GPSs. Serial cable connection was the way most older GPSs were interfaced. This requires a direct cable connection between the PC and GPS. This is sometimes complicated by lack of a serial port on the PC necessitating a USB to serial converter. More recently the use of the memory chip or card has become the preferred way, as it does not require that the PC and GPS be brought together. It is also easier and in some cases allows at-sea changes in the loaded waypoints without a PC present. See the import/export chapter on doing memory card waypoint transfers. If you want to pursue the direct cable transfer method, read further.

When Lowrance/Eagle Upload/Download is selected, a window is displayed that allows you to initialize communications with the GPS, get product information, and upload/download waypoints, routes, plot trails, and icons. The icons and waypoints can be downloaded as standard data files, the routes as trip plans, and the plot trails as tracks. In the GPS, icons are waypoints that you have saved as icons as opposed to waypoints.

The first step in connecting with the GPS is setting the port and communications speed. Be sure that the data cable is connected and the GPS is set into the right mode. It may be necessary to turn off NMEA output, disconnect any differential receiver and turn off DGPS activity. Write down the original configuration and settings so that you can restore them later.

Go to the GPS's System Setup screen and set the Com settings to 19200 baud, 8 bits, and no parity. Then, from the Upload/Download window, set the COM port to the PC serial port that you have connected the data cable to and set the baud rate to 19200. Note; if a rate of 19200 does not work, try lower settings at both ends.

Push the **Initialize** button and the program should connect as shown by the word "Initialized" on the Status line and the product ID should be displayed. At this point, you are in control. If you close this window, you have to reinitialize the connection to the GPS if you again open it.

The Lowrance window will have information as to how many waypoints the specific GPS can store and so forth. For upload and download, the program places the Lat/Lon information in the **Lat/Lon** field and the 8 to 10-character waypoint name in the **NAME** and **DESCRIPTION** fields. The first step you take should be to download whatever is in the GPS' memory to a file so that it can be saved, you can see what type of information is available, and see how an upload file should be configured. You can then reorganize this file or create another to upload to the GPS. There are four tabbed pages to the Upload/Download window that allow you to look at waypoints, plot trails, icons, and routes. Waypoints and icons are translated to data files, routes to trip plans, and plot trails to track files.

Remember several points about the GPS. First, it is desirable to leave some empty waypoints in the GPS for on-the-spot waypoint saving. Indeed, one of the useful operations for the program for Lowrance is to erase a block (or all) of the waypoints to clear the way for more on-the-spot waypoint saving.

Second, all waypoints are put in numerical order just like in the program. This means that they can have duplicate names unlike some other brands of GPS. Third, the Program will upload as many waypoints as you have in the file up to the maximum storage available. Also, if you want some specific points in the GPS in specific locations, put them in the file. For example, it might be useful to
use WPT-002 for a navigate-to setting and WPT-001 for the inlet. They are easily available when the unit is first turned on. When you download the GPS, you will notice that some waypoints are blank. To upload a file like that, you either need blank waypoints in your file, or you need to put junk waypoints there and later erase them using the Delete Waypoints operation.

In order to download a route and make it into a trip plan, the waypoints must first be downloaded from the GPS since the route depends on the numbered waypoints. That is, a route is a sequence of waypoint numbers, so the waypoints must correspond to the route. When you are done, you can examine the route from the Trip Planner. You can also save it or print it from there.

**FURUNO (NAVNET)**

There are two basic ways to transfer data to and from most GPSs. Serial cable connection was the way most older GPSs were interfaced. This requires a direct cable connection between the PC and GPS. This is sometimes complicated by lack of a serial port on the PC necessitating a USB to serial converter. More recently the use of the memory chip or card has become the preferred way, as it does not require that the PC and GPS be brought together. It is also easier and in some cases allows at-sea changes in the loaded waypoints without a PC present. See the import/export chapter on doing memory card waypoint transfers.

Waypoint transfer from a Furuno GPS to PC for the GP30 line of products must be done via serial cable (7 pin cable (Furuno part # 000-145-612) to serial connector). You may have to solder on the serial connector to make this cable. Use the Furuno loader supplied with the program to effect the transfer. It creates a file in the DMX form that can be imported/exported.

Waypoint transfer from a Furuno GP1650/1850, Furuno NavNet, or GP7000 to PC can be done via serial cable or by utilizing a memory card in either FP or SD format. The GP1650/1850 cable is a 7 pin cable (Furuno part # 000-136-730) to serial connector. There is a pre-made cable FUR-DWN-CBL. The Furuno NavNet and GP7000 cable is a 7 pin cable (Furuno part # 000-154-028) to serial connector. There is also a pre-made cable NET-DWN-CBL)

To make the hardware connection to your computer from your GP32, you should follow the wiring instructions in your operator's manual. If you have lost your manual, it is available on Furuno's web site under manuals and documents. There isn't a pre-made cable made for the GP32 because the serial connector must be wired to your existing power/data cable.

**Serial cable transfers**

If you are using the serial transfer method for the GP30 series and possibly all the others, you need an interface cable to connect the GPS to the PC. This transfer uses the companion Furuno loader that is found in the Programs> LoranGPS group. Go to the PC’s start menu and select Programs or All Programs. Look up the LoranGPS group and select Furuno. This brings up the Furuno loader screen.
This program was developed for the Ozi Explorer and not by the Andren Software Co. Thanks to the OZI folks for allowing it to be used for this application. After connecting the GPS to the PC set such GPS things as NMEA PORT1 with the output format set to NMEA0183 Ver2.0. Make sure that the port can communicate both ways (input and output) and not just output. Now, on the PC in the Furuno program, set the Port to what the GPS is connected to. If you are unsure of this, try to Read GPS with various settings. Once a GPS is found and communicating, it will fill the blank part of the form with data it is receiving. You may have to go to the GPS to tell it to transfer data. I don't have a Furuno to try it on or I would have filled in the example above. If your PC does not have a serial port (it looks like the monitor port, but is male instead of female) then you need a USB to serial converter device.

To see where your GPS is connected, you can go to the Control Panel from the START menu and select System>Hardware Tab>Device Manager>Ports. This will usually tell you what port is active. Mine says: "USB Serial port (COM4)".

Now, we are ready to use the downloader program.

Download (from the GPS)
-----------------------
- Select the "Read GP30" button to download the waypoints from the GPS.
- Select the Datum you are using with the GP30; normally WGS84.
- Select the "Write Ozi" button to save these to an Ozi import/export file (Furuno DMX).
- Andren LoranGPS can import this file (it is in the Furuno DMX format).
  The option is in the Tools>Import>Furuno DMX menu

Upload (to the GPS)
-------------------
- Create a file with Andren LoranGPS and export the waypoints into Furuno DMX format.
- The Option is on the Tools>Export>Furuno DMX menu
- In the Furuno software select the "Read Ozi" button to load the DMX file.
- You should see the waypoints in the window that look like the waypoints downloaded from the GPS. They look like:
See the import/export section for additional information on naming conventions for Furuno and how to do the transfers via a memory card.

**Garmin**

In the Garmin GPS, set the mode to GRMN/GRMN or Garmin Data Transfer proprietary protocol. For Garmin interchanges set the speed to 9600 baud. The program will attempt to find the right COM port automatically. It should try to initialize immediately and will show the results on the screen. For example, it will show the Product Identification (PID), a description of the GPS, the current Lat/Lon/altitude, the estimated position error, the date, and the time. Some of these may not be present if the GPS has not locked on to the satellites. If it fails to communicate at all, a message to that effect will be displayed. If the communications parameters need to be changed, there is a menu item in the upper left corner of the pcGarmin screen called Comm Settings. This will allow you to set the port and baud rate and to make a diagnostic log of all communications. For USB operation, the Comm port should be set to USB unless you are using a USB to serial converter. Once communications is accomplished, the GPS identification will be displayed and traffic will be evident in the window.

You have many functions to choose from, but the first should to be Get Waypoints so that whatever is stored currently in the GPS is backed up to the PC. Then you can Send Waypoints to the GPS assuming you have set up a suitable file to upload. In the Garmin, the waypoints are put in alphabetic order, so it is important to not have duplicate names. If you do not erase all waypoints from the GPS first, uploaded waypoints will overwrite waypoints of the same name. The program will attempt to eliminate duplicates in the uploaded file, but it does not check to see if a waypoint of the same name is already in the GPS. Therefore, it is best to download all waypoints, combine this with any you want to upload, erase all waypoints in the GPS, and then upload the new file. See notes in the Lowrance section above for more handy tips.

**Magellan**

For Magellan, set the speed to 4800 baud and it will find the right COM port. It should try to initialize immediately and will show the results on the screen. If it fails, a message to that effect will be displayed. For the Magellan, the waypoints are put in alphabetic order, so it is important to not have duplicate names. Again, names are the first 6 or 8 characters of the Description. See notes in the Lowrance section for more tips.

**Northstar**

This support utility is available to upload and download Northstar GPSs. You also have the option of using Northstar's own loader (DB_LOAD). If you use DB_LOAD, you use the import/export NMEA routines to interface with this loader.

**Introduction**

The NorthStar loader is intended to upload and download waypoint files to and from NorthStar GPSs like the 941/951 but not the 961. It may work on the 6000i also. It is a utility that is used by the Andren LoranGPS program as a utility and is normally loaded as a support file during installation. It can create a dBase III style file of the downloaded waypoints in the format of the Andren program. It can also take such a file and upload it to the NorthStar. This utility can also be used independently from the Andren LoranGPS program to enable upload and download of the NorthStar to a universally
recognized file format (dBase III). You need a WA215 interface cable to connect the NorthStar to the PC. Call your NorthStar dealer if you need one.

**Rules**

The Northstar stores waypoints by NAME in alphabetical order. Names are the search key for the Northstar. This means that no two NAMEs can be the same. NAMEs are 6 characters long and follow certain rules.

Saved waypoints' NAMEs begin with a dash and have a specific description generated by the unit. NAMEs that are only 4 characters long are associated with saved routes.

On downloading, the names of the waypoints will be used as first 6 characters of the Comments field and can be re-uploaded later.

If, on uploading, the "use Comments for Name" box is checked and the first 6 characters of the Comments field are blank, the Northstar loader utility will create NAMEs that are the waypoint number in your list. i.e. 001, 002, 002, ……999

This will keep the waypoints in the same order as your printed list and look good on the display.

If there are residual waypoints in the Northstar, the waypoint numbers will start at that number and increment upwards from there.

All names and descriptions must be in upper case. The utility will convert them if they are not.

Characters not available from the Northstar's keyboard are removed before uploading to the NorthStar to avoid problems.

The uploader will use the first 16 characters of the description as the waypoint description.

The downloader will store the avoidance radius as the second 6 characters of the Comments field. On uploading, if the data in the Comments field is a number from 0.01 to 1.00, it will use that as the avoidance radius.

The NorthStar does not report icons associated with the waypoint to the utility, so they are lost in the translation.

**Instructions:**

The NorthStar must be set up to see the proper communications port. Remember to record any changes you make to the configuration so that you can undo them later to restore the GPS to its original configuration.

Push the star (*) key enough times to see the User Customization tab

Push the Port Setup Options tab and go to the RS232 Setup; edit

Set the RS232 port to Copy Port 1 and use 4800 or 9600 baud.

Connect the interface cable to the computer’s serial port. (COM1 or COM2)

**Run the NorthStar Loader Utility**

The NorthStar utility starts when called from the Andren LoranGPS program's **Tools>Upload/Download>NorthStar** selection. You normally enter as either uploading or downloading. Keep in mind which one you used as the NorthStar loader does not know or care, but the subsequent actions by the Andren LoranGPS program depend on it.

Select the COM port. On old desktop computers, the mouse is on COM1 unless it uses a PS-2 mouse so try COM2 too.

The very first step should be to verify that communications is established by pushing the test communications button. If all is well, the utility will read the software version from the Northstar and report it in the activity window. If the communications is not established, then try other communications settings until it is.
Then download what is in the NorthStar to save it. This utility creates a file called "north2logps.dbf" and then waits for further instructions. Quit the NorthStar loader to return to the Andren LoranGPS program.

For Downloading from the Northstar to the PC:
The steps of operation are as follows: First the program halts and calls the NorthStar loader utility. The NorthStar loader utility reads the waypoints from the GPS and creates a file called: north2logps.dbf. Then the user quits the NorthStar loader and control returns to the program, which then reads the file and makes it the current file. You should "Save As" the file to a different name after you are done. If any of the waypoints were stored as a Loran number set the Loran Chain for the program. The Loran Chain is an artificially selected number from 1 to 8 that only has meaning to the Andren Software Co. program.

For Uploading from the PC to the Northstar:
The steps of operation are as follows: First the program saves the current file to the disk as: logps2north.dbf. It then halts and calls the NorthStar loader utility. The NorthStar loader utility reads the file and writes the waypoints to the GPS. Then the user quits the NorthStar loader and control returns to the program.

Others
You can upload and download some GPSs with a standard terminal utility such as HyperTerminal found in the Windows Start>Programs>Accessories>Communications folder. This will let the GPS do the work and create a file on the PC or read a file into the GPS. Normally, this file would be a NMEA 183 formatted file that can be imported and exported by the program.

Import File
The file structure used by the program is dBase III that is widely recognized. If you have a database of waypoints in some other form and want to import it into the program, use one of the routines in this section. These files might come from reading memory cards written by your GPS. If you have a file with one of the extensions: GDB, GPX, MPS, RWF, USR, or XML you can open them with FILE>OPEN which will call one of the import routines that follow. If you have a file from the legacy DOS versions of the program, use the FILE>OPEN routine.

Many of the file types exchanged between a GPS and a memory card are binary files. These files are not readable by a text based program like Notepad. All you get is hieroglyphics with a few
recognizable characters thrown in. None of the binary file types are documented by their creators, so it has been my task to decipher them well enough to be able read and write them. This understanding is not complete, but it is functional. Handling multiple variants is tough, so I have tried to import all that I have seen, but export only the most generic.

One of the stumbling blocks to transferring waypoints between brands has been the handling of icons. No one seems to have a standard set. Many brands have icons of no use to fishermen, so those I have translated as best as possible to useful icons in the LoranGPS set. Garmin, for example has icons for many uses other than marine, so most of them are ignored.

If you have a Garmin, Lowrance, Eagle, Furuno, Magellan, NorthStar, Sea-Nav, Simrad, or Raymarine GPS, you should be able to use the built-in upload/download or import/export capability of the program in lieu of using another program to upload and download the GPS. Most new GPSs have the ability to load and save the waypoints as files onto a memory card of the SD, FP and CF varieties. The program has import/export utilities to handle most of these files. The following list shows the GPS track Plotters known to be compatible with this program.

**GPS Track Plotters:**
- C-Map XML or userimg.bin for any GPS that uses C-Map cards
- Eagle USR
- Furuno GP30 serial cable connection
- Furuno DMX
- Furuno NavNet 2 RAT/ROU or BIN
- Furuno NavNet VX-2-3D CSV
- Garmin serial cable connection
- Garmin/Mapsource GDB or MPS
- Garmin USERDATA.ADM
- Lowrance USR, WS1
- Magellan serial cable connection
- Northstar NMEA NTI or userimg.bin
- Northstar 941/951 serial cable connection
- Raytheon NMEA WPL
- Raymarine C/E series archive.fsh
- Raymarine TXT
- Raymarine Waypoint File RWF
- Simrad userimg.bin
- Simrad USR, XML
- Sitex userimg.bin
- Standard Horizon NMEA WPL

Using this capability, you can move your waypoints between brands and models when upgrading your GPS. An attempt is made to match Icons between brands, but this cannot be guaranteed.

If, however, you are trying to work with another program or data source to import or export data, this list shows other the programs that handle waypoints and that the LoranGPS can exchange data with

**Programs and file types**
- ASCII (pure text in CSV format) with selectable fields
- C-Map PC Planner
- EasyGPS *.GPX
- Fugawi *.FWP
- Garmin PCX5
Gardown10, *.txt  
G7TOWIN, *.txt, *.WPT  
GPSUtility  
GPX  
Humminbird PC  
Loran Locator LX or AX  
Lowrance GDM6, LS1  
MaxSea (for Furuno)  
Mapsource *.MPS, *.GDB for Garmin  
Maptech marks.rec or mark32.txt  
NMEA GLL, RMC, GGA, GLC, WPL, RMA, CLF, NTI, and FEC  
Northstar WinDBLoad (nswptldr.exe), DB_UNLOD.EXE *.PNTI  
Offshore Hunter text export  
Ozi-Explorer *.DMX  
P-SEA WindPlot  
Raytech Planner, Raytech Navigator, PCwaypoint  
XML  
Others; using GPS Babel

The following are the details on each file type.

**IMPORT ASCII (pure text/CSV)**

ASCII is a pure text form of data file according to the American Standard Code for Information Interchange. This import routine accepts files in Comma Delimited Variable (CSV) form with many different organizations. They are selected via the Import Options screen:
The program will open the comma or tab delimited files and show the first line on the screen. If the first line of the file is not a row of data, you might want to first edit the file with Windows Notepad and remove non-data rows. They might crash the import routine. Otherwise, push Show Another Line to get to a data line. Looking at the displayed data, you pick the program fields that you want the data put into. All input data fields must be accounted for. That is, if there are 8 fields in the source data, you must have 8 fields selected to put it into as shown in the example screen shot above. Some fields like Lat/Lon are inherently doubles and are counted as 2. If you count the commas, there should be one less than the number of fields. The above example has 7 commas for 8 fields.

The structure of these files is called comma delimited (CSV), which means that all fields are separated by commas (or TABs). All text fields may be also enclosed with quotation marks but don't have to be. If your text fields have embedded commas, replace them with something else like semi-colons.

Note that the longitude might be shown as negative. This is correct and is a standard worldwide convention for West longitudes. This program uses a non-standard plus sign for West longitudes since the vast majority of our customers are in the USA and this avoids extra keystrokes. However, when exchanging data between other programs and this one, it may be necessary to use the conventional sign. A check box allows you to change the sign if the source uses the other choice for sign. If the latitude and longitude include non number parts other than degree, minute and second symbols or N/S indicators, the program may not be able to handle it. Separated degree and minute fields are another nono.

**Import C-Map files**
Quite a few GPSs use C-Map cartography and those usually have the capability to save files to a chart card in this format. For these units that use C-Map cartography, you can use this program to import/export waypoints to them. For those units using an SD card, the import/export routines will read or write the data to the card. The file is named "userimg.bin" and is a binary file with the capability of having multiple (up to 60) sub files within the same file. The import routine will show the multiple sub files, if they exist, and allow you to select one or more to import. Each time you save your waypoints to the card with the GPS or PC-Planner, it creates a new sub file. On exporting from the LoranGPS program, however, only one sub file will be exported. That is, it will delete those earlier sub files. If the unit uses the proprietary C-card (a.k.a. FP card) memory card, then you will have to use the C-Map software PC-Planner and its associated card reader to read and write the files. Suitable, non-proprietary readers are not available for C-cards.

**IMPORT Fugawi ASCII**
The program can import the files exported by the Fugawi utility in ASCII (pure text) format.

**Import Furuno/OziExplorer DMX**
The program can import the DMX file that OziExplorer or the Furuno downloader exports. This is a file that is downloaded from the Furuno GPS30 by the companion Furuno utility.

**Import Furuno (And Navnet)**
You get several choices for Furuno transfers. If you use the Furuno and a terminal program or the companion Furuno loader, you will get a file saved on disk that is either a DMX file or a PFEC file. These are text files that can be imported. If you save your waypoints to a memory card, then use the following instructions.
To use an FP card (as opposed to an SD or CF card) you must use the C-Map PC Planner software and card reader to read and write the card as it uses a proprietary format not recognized by a PC without the C-Map driver. The program can handle the *.UP.WPL format of PC Planner.

Using an SD card is easier as you may insert it directly into any SD card reader. Many laptops come with a built-in SD card reader. The Furuno GPS will read or write two files on the card named: "GP1650B.ROU" and "GP1650B.RAT". These are the default file names. These can be directly imported into the program. If, for any reason, you have problems with this import routine, you can use the free software: MaxSea Planner available from Furuno dealers (but not on the Internet). This program will import the RAT/ROU files and export a GPX file with the data. Then that GPX file can be imported/exported via the GPX import/export routines.

Instructions for the Furuno GP1650 NavNet 2 units.

To load data into a memory card from a NavNet VX2 use the following string of commands. B stands for Button, SK for soft key, and T stands for track ball or rocker.

<table>
<thead>
<tr>
<th>Key</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Menu</td>
</tr>
<tr>
<td>SK</td>
<td>System</td>
</tr>
<tr>
<td></td>
<td>Configuration</td>
</tr>
<tr>
<td>SK</td>
<td>Data Transfer</td>
</tr>
<tr>
<td>SK</td>
<td>Upload/Download</td>
</tr>
<tr>
<td></td>
<td>saved data</td>
</tr>
<tr>
<td>SK</td>
<td>Save data to</td>
</tr>
<tr>
<td></td>
<td>memory card</td>
</tr>
<tr>
<td>T</td>
<td>Dn, Dn to turn waypoints &quot;ON&quot;</td>
</tr>
<tr>
<td>SK</td>
<td>Edit</td>
</tr>
<tr>
<td>T</td>
<td>Up</td>
</tr>
<tr>
<td>SK</td>
<td>Enter</td>
</tr>
<tr>
<td>SK</td>
<td>Save</td>
</tr>
<tr>
<td>B</td>
<td>Enter</td>
</tr>
<tr>
<td>B</td>
<td>Enter</td>
</tr>
<tr>
<td>B</td>
<td>Menu button</td>
</tr>
</tbody>
</table>

Do the same for loading, but choose Load instead of Save. Once the files are on the card, just put it into the PC card reader and import the file with this selection.

MaxSea Planner transfers (SD card)

If you need or want to use the MaxSea Planner software, do the following:

First, set up the device identity. Go to the Route menu and pick Device Upload/Download. Then select Configuration and pick the last transfer protocol: Furuno SD Card. Finally, push Next and Finish. Now the software is set to do all uploading and downloading via the card.
To read what is on the card (download GPS) go again to
**Route>Device_Upload/Download>Download from GPS.** This will bring up a screen that allows you to show it where the SD card is in a browse window. Open up My Computer and then click on Secure Digital storage device. Then push OK. The data from the GPS should then appear on the screen if you are scrolled to the right area. You can see a list of the data by using the menus: **Display>Center>Waypoints.** Don't ask why. Verify that your waypoints have been captured either on the map or the listing. Now, use the menu commands: **Route>Export** and you get a Save As screen that allows you to save the file as a GPX file in a location of your choice. Put it into the C:\LoranGPS folder with an appropriate name like: "Furuno-download-070831.GPX". In the program go to **File>Open File.** Change the Files-of-Type to all files (*. *). The Furuno file should show up and you can double click on it to open it. The TDs columns will be unfilled. If you want them filled with computed Loran TDs, go to **Tools>Convert Loran** and pick the appropriate Loran chain. You can now combine this data with any other file if you want and otherwise manage the data. If you are not planning to change what is in the GPS, then I would suggest you print the listings and charts of this data so you have a hard copy of what is in the GPS.

You can take any program file and export it to a GPX file format and reverse the above procedure. Keep in mind how many waypoints will fit into the GPS and how you want it organized.

**C-MAP PC Planner transfers (C card)**

In PC-Planner we use the File Manager function under the File menu. This form shows two panel pairs with transfer arrows between them as shown below.

![File Manager](image)

We can set each panel to the appropriate location to do a transfer. For example, the above figure shows us ready to transfer a file from the program to the PC_Planner memory (internal database). Files for PC_Planner have a unique naming convention. They have a name followed by .UP.XML. Once files are in the PC_Planner memory, they can then be transferred to the FP card. In navigating on this screen, the folder with two dots following it is an old style shortcut meaning go up one level in the directory tree.

If you go to the "View" option on the tool bar on PC Planner, then "settings", you will see several options a.) Generic, b.) Furuno, c.) GP-7000, and d.) NavNet 2. The correct settings may depend on what model you have.
The Furuno GP7000 uses a file structure with the file name userimg.bin (developed by C-Map). This unit can store 2000 waypoints. The maximum length of the Name is 12 characters and for the Comments is 13. You have a choice of 8 colors and 16 icons. For the SD and CF card types, you can use the Furuno>GP7000 import/export capability. Keep in mind that the names should be unique. Colors and icons will be translated to the program's set as applicable.

Instructions for Furuno NavNet 3D transfers.

The menu arrangement of this model is somewhat different from previous models. Going from recollection, here is the sequence of operations to get your data saved to the SD card. Push the Menu button. This brings up a list of icons on the left side of the screen one of which is File. Use the rotary knob to scroll to the File icon and then push the knob to select it. This opens a screen with options like Export Points and Routes. To save your waypoints select this one and you should get another screen that says: "an SD card has been found in slot A or B, do you want to use it?". Use the rotary knob to select YES and push the knob to do it. Then, you get a screen wanting a name for the file. You use the knob to select letters or numbers for the file name by the rotate/press technique. Once you have completed the file name, press the knob another time. This should cause the GPS to save all the points to the card in a set of 4 files. I did not notice any indicator of progress or finality, so wait a minute or so before removing the card from the machine and putting it into your PC. With the program, use: TOOLS>IMPORT FILE>FURUNO>FURUNO NAVNET 3D SD CARD. This should get you a file opening dialog that is looking for a *_wpt.csv file. Navigate to the SD card drive and the file you saved should show up. Select your file and it should open and be displayed.

The Icons in the GPS are currently not exactly converted to program icons as they are very hard to read in most cases.

Naming conventions

Many but not all models of Furuno use the following naming conventions. The short name in the GPS is 6 characters long (except GP7000) and there can be no duplicates. The only allowed characters are those that can be entered from the keyboard of the GPS. These include the numbers and upper case letters. The only punctuation allowed is the hyphen, the underscore, and the pound sign. With these facts in mind, the program will go through a file and make sure there are no duplicates, replacing any non-allowed characters by allowed ones. Spaces, for example are filled with hyphens.

If the file to be exported is longer than will fit in the GPS, it can be split on exporting. As an example, my 80 Ft reefs file is 2563 waypoints and only 1000 will fit. So, I split it as the first 950 in one file, the middle 950 in another and the last 950 in a third. This gives me about a 200-waypoint overlap between files and leaves 50 waypoints free for at-sea capture. So, you ask, how can I put these three files on the SD card if they are all named the same? The answer is to load three or more cards. Then label the cards as to their contents. These cards can be pretty small and therefore cheap as the files are small. Old camera cards will do. By the way, I have heard that certain Furunos only accept 128 MB cards. These are no longer sold retail, but you can probably buy them on E-Bay. If your GPS model allows you to name the files, then you can put multiple files on one card. A 128 MB card can hold over 128 files of 1000 waypoints each.
Problems

John McWhite has discovered an issue with the new Furuno Vx2 GPS plotters. They will not transfer the total number of waypoints written to a chip. There is no pattern to it as they have tested multiple units. Everything is right on the chip, and the conversions made by the software work in other 1650 and 1850 units. It seems those Vx2 units running software versions ending in 07 have this transfer issue. If you have this problem, check Furuno for a version ending in 08.

Another thing to note is the limited name length. If you have named your waypoints with names longer than the GPS can handle, the names will be truncated. This may create duplicate names, so later waypoints will overwrite earlier ones in the import process. This will result in fewer waypoints being loaded than expected. To cure this will require that you reduce the name lengths to what the GPS can handle and then check and fix duplicates.

The new NavNet 3D models sometimes lock up requiring a reboot when doing complex operations. In addition, they do not have obvious indications of completion for some file transfer or waypoint deletion operations.

**IMPORT Garmin**

The latest Garmin track plotters and combo units use an SD card for maps and data transfer. This makes it very easy to get your data into and out of a Garmin. This has been verified to date on GPSmap 440s, 541s, 545s, 4208, and 5212s. Garmin stores waypoints by name, so no two names can be alike.

To get waypoints from Garmin GPS to PC:
1. In GPS save waypoints to the SD card by: **Home>Information>User Data>Data Transfer>Card>Save to Card**
2. Remove card from GPS and insert into PC card reader
3. In LoranGPS, go to **Tools>Import File>Garmin>Garmin USERDATA.ADM**
4. Navigate to the SD card, open the Garmin folder and then the UserData subfolder to get at the file.
5. Then fetch the file and you are done.

By the way, some Garmin GPSs like the 4208 do not display the Comments field even though it is included in the file imported. It may also not export the Icons. Some of the Garmin units allow a choice of file names, so you can have several files on one chip and can then change out the waypoints at sea. Those that do not allow you to name the file will insist on having the file named "userdata.adm". Importing a Garmin ADM file is a necessary step in initializing the SD card for later exporting to the GPS. The GPS sets up the folder structure needed and also writes a file that identifies the GPS model and also the software model for the ADM file.

The program can also read and write the GDB files found on some CF memory cards, but you need a CF card reader on your computer.

**IMPORT Garmin Mapsource**

Some people prefer to use MapSource by Garmin to upload and download their receivers. In Mapsource, the menu items are: **Transfer>Send to Device** or **Transfer>Receive from Device**.

If you want or have to use Mapsource to do the upload/download, the Andren LoranGPS program can read/write files that work with Mapsource. That is, you can save GPX, MPS, or GDB files with Mapsource (using Save As) that the program can import/export. In addition, Garmin has an older program called PCX5 (PC software kit) that could download and upload a variety of old Garmin GPS receivers. The program can read and write these PCX5 waypoint (and GPX) files and Mapsource can also read PCX5 (and GPX) files. So, to get files from the program to Mapsource, just export them as GDB or GPX waypoint format and then open them in Mapsource (Hint, use: Files of Type).
**IMPORT GPX**
This is a GPS exchange format found on the Internet. Garmin, for one, has embraced this form in their Mapsource program. You can import/export data in this format. The files are textual and can be easily read and edited. Just make sure that you follow the structure of the GPX format.

**IMPORT Humminbird**
If your Humminbird uses the C-Map cartridge, you can use the C-Map importer for this transfer.

**IMPORT Lowrance/Eagle/Simrad**
The program will handle the *.USR files found on the SD memory cards of Lowrance based GPSs. In the GPS, you go to the System Setup menu and select Transfer-My-Files. Transfer the file in memory to the SD card. It normally gets named 'data.usr' but you can change that to any name you want. Once the contents of the GPS are on the card, you remove it and insert it into the card reader of your PC. All you have to do then is Open the file or Import the file with the program. It will get converted and you can combine the data with your other information. To open a USR file with the Open menu, change the Files-of-Type to *.* and then find the file and open it. If the Loran TD columns are not filled in and you want them to be, you can do so by selecting Tools>Convert Loran. Exporting is the reverse of this procedure, but you get additional choices for how many to export. That's in case you have more in the file than the GPS can handle. See the Export section below.

Lowrance also has a program called GPS Data Manager (GDM6) that can handle many of the legacy machines and the program can import and export the USR files it needs. If you have an older GPS that this routine will not work on, Lowrance, has an obsolete program called WS-1 (PC interface kit) that can download and upload the older variety of their GPS receivers. This import routine can read the WS-1 files and extract the way point information.

**IMPORT LORAN LOCATOR**
The program also imports the files of the obsolete and no longer available LORAN LOCATOR program in either the (LX) version or the (AX) version. The old files will have one of the following types of names: LOCATION.DAT or: LX50BOOK.DAT where the [DAT] may be replaced by 3 user specified characters. The field structure of LX and AX files does not match the program's so some liberties are taken in the conversion. If the imported file's Lat/Lon fields are zero, use Tools>Recalculate Lat/Lon.

**IMPORT MAPTECH**
The program will import the MARKS.REC files of RESOLUTION MAPPING's NAV PRO or MAPTECH programs. The basic data is Lat/Lon and is placed into the TD and L/L fields. Some of the other information is placed into the RATING, DESCRIPTION, DATECODE, and COMMENTS fields as appropriate.

**IMPORT NMEA 183**
NMEA standard sentence structures, GCL, GLL, GGA, WPL, RMA, CLF, RMC, and PNTI from standard Loran and GPS receivers have navigation information that is of interest. The last one is a proprietary format from Northstar's DB_UNLOD.EXE. If these data outputs are downloaded into a file, that file can be imported into the program. The basic data is Lat/Lon and is placed into the L/L
fields. Some of the other information is placed into the NAME, DESCRIPTION and COMMENTS fields as appropriate.

**IMPORT Northstar**

One NMEA proprietary sentence structure "PNTI" is output and input by Northstar's WinDBLoad or DB_UNLOAD (a DOS program). These data outputs are downloaded to a file that can be imported into the program. Those Northstar units that use C-Map cards can use the C-Map transfer method described earlier.

**IMPORT Northstar M series**

This unit is basically a Navman GPS rebranded. For those units using an SD card, the import/export routines will read or write the data to the card. The file is named userimg.bin and is a binary file with the capability of having multiple (up to 60) sub files within the same file. The import routine will show the multiple sub files, if they exist, and allow you to select one or more to import. Each time you save your waypoints to the card, it creates a new sub file. On exporting from the program, only one sub file will be exported. That is, it will delete those earlier sub files.

Those Northstar units that use proprietary C-Map cards can use the C-Map transfer method described earlier.

**IMPORT Offshore Hunter’s text export**

Offshore Hunter exports a text file with a comma-delimited format. The program can handle that with this menu item. If the Loran TD fields are blank, you can fill them using Tools(Convert Loran).

**IMPORT P-SEA WINPLOT**

The program will import the MARKPNTS.DAT files of RADAR COMMUNICATION's P-Sea WinPlot program. It places the first 32 bytes of the 71 byte description into the DESCRIPTION field and the rest into the COMMENTS field. It places four parameters, comma delimited, after the description. These are the RBon, Symbol, and two numbers. You can add to this file using Loran TDs that will be converted to Lat/Lon. We recommend also writing TDs in the DESCRIPTION field so they will be retained if the file is later exported back to the P-SEA program. You need not be overly concerned with the five parameters following the description as they can be fixed in the P-SEA program if needed. The color white is shown as dark gray.

**IMPORT Raytheon and Standard Horizon**

One NMEA standard sentence structure "WPL" is output and input by Raytheon and Standard Horizon GPS receivers when using a terminal program. If these data outputs are downloaded to a file, then that file can be imported into the program. The basic data is Lat/Lon and is placed into the L/L fields. The waypoint name is put into the NAME field. You might need to use a terminal program like HyperTerminal in the Windows>Accessories>Communications shortcut folder to do the downloading.

**IMPORT RayMarine**

Raymarine has a proprietary file format that is named "Archive.fsh". The program can import/export that file structure. Since all files exported by a GPS are called "Archive.fsh", you may need to get several cards if you have more than one file. Fortunately, small capacity cards like 128 MB are sufficient.

If the GPS was set up with multiple folders, you may get some duplicate waypoints as they might have been located in different folders. You can later do the duplicate search to find duplicates and near
duplicates that you had entered into the GPS. On exporting to the GPS you will only get one folder: My Waypoints. You can then rearrange the folder structure in the GPS if you wish. This will be fixed in a future update.

If there is any problem, they have a free utility on their web site available to registered users called RayTech Planner. Use the RayTech Planner Utility to export a RWF file. In RayTech, Select File> Import/Export Routes and Waypoints> Export to File> Export to Raymarine Waypoint File to save as a file in the Raymarine Waypoint style. This file will probably be saved in the C:\Program Files\Raymarine\Raymarine RayTech Navigator\Archive folder. Alternatively, it might be saved to: C:\Archive. Then use the TOOLS>Import file> Raymarine RWF to import the file. You will have to navigate to where the file is to get it. See the export section that follows for more details.

**Warning.** Be very careful with Raytech Planner. All waypoints are imported into it as unlocked. What this means is that if you touch a waypoint on the plot screen with the mouse cursor, it will move to follow the mouse. This strange behavior was designed in and intended to allow you to easily move points around. However, for fisherman, this can be disaster. There are two ways to lock all the points while using this tool. First is to open each and every point and lock it. The second is to exit Raytech and find: C:\Program Files\Raymarine\Raymarine RayTech Navigator\marks.dat and open it with Notepad. Then do a global search and replace of Locked=0 with Locked=1. Save the file and open Raytech and all points currently displayed will be locked. If you import another file, then it will again default to all unlocked.

**IMPORT RayMarine TXT**
The older RayMarine PC Waypoint Utility's tab delimited text file version of their Excel file can be handled by this routine. That is easier than doing column copy/paste operations in Excel.

**IMPORT Simrad, SiTex, Standard Horizon, Humminbird**
To the extent that these units use C-Map cartography, you can use this program to import/export waypoints to them. For those units using an SD card, the import/export routines will read or write the data to the card. The file is named userimg.bin and is a binary file with the capability of having multiple (up to 60) sub files within the same file. The import routine will show the multiple sub files, if they exist, and allow you to select one or more to import. Each time you save your waypoints to the card with the GPS or PC-Planner, it creates a new sub file. On exporting from the LoranGPS program, only one sub file will be exported. That is, it will delete those earlier sub files.

If your card type is C-card or FP, you will need to use the C-Map PC-Planner software access the memory card. You would most likely choose the "generic" setting, which does change the looks of the file on the chart background (icons, etc.). For importing, have the PC-Planner software read the card and then save an XML file in a convenient location and then import that into this program. For exporting, convert your data from a dbf format to xml using the program, then open it with PC Planner and write the finalized file to the card.

**IMPORT Others**
Through the use of the GPSBabel utility, a large variety of GPS data formats can be converted from one to another. Of these, the GPX format is a good one to use to get the data into or out of the program. A copy of GPSbabel is included with the program. GPS Babel is an open source software program free to anyone to use and is user supported. To use it, you select Tools>Import File>Other Formats. This brings up the GPSBabelGUI-2 screen. There is a zipped ReadMe file on the CD that has instructions if you need them. GPSBabel is not marine oriented, so it does not have all the translations you might need.
For GPS units that use the C-Map cards, you need the PC-Planner software to read and write these cards in their proprietary format. I do know that for Simrad and Standard Horizon, you must choose the "generic" setting, which does change the looks of the file on the chart background (icons, etc.). I am assuming that SiTex and Humminbird will most likely take the same setting. If you go to the "View" option on the tool bar on PC Planner, then "settings", you will see several options a.) Generic, b.) Furuno, c.) GP-7000, and d.) NavNet 2. The correct settings may depend on what model you have. Whatever works for downloading the data from the card to the PC should work in the other direction. You would normally convert data from a DBF format to XML using Andren LoranGPS, then open it with PC Planner and write the finalized file to whatever card is required. It might not be the best way of doing things but it does work. PC Planner can get a little screwy at times though.

**EXPORT FILE**

The program will export files that can be imported by the routines listed above. It will not export all NMEA file types, just the WPL and PNTI varieties.

ASCII (text) in various formats, comma separated variable (CSV)
C-Map userimg.bin
Eagle USR
Fugawi ASCII
Furuno NavNet CSV, DMX, BIN, or RAT/ROU
Garmin/Mapsource GDB or MPS
GARMIN USERDATA.ADM
Garmin PCX5
Gardown10
GPX
Lowrance USR
Maptech
Northstar M series and PNTI
Offshore Hunter text
P-SEA WindPlot
Raytheon NMEA WPL
Raymarine Archive.fsh
Raymarine TXT
Raymarine Waypoint File RWF
Simrad userimg.bin, USR
Standard Horizon NMEA WPL
XML
Others using GPS Babel

To export an ASCII comma delimited text (CSV) file in an arbitrary format that might include range and bearing, you first set up a format with the fields you want in the export using the Export Options form.

In all the exports that target loading waypoints into a GPS, an Export Options dialog comes up to help you select what is to be exported.
In some cases, the file will contain more waypoints than can be stored in the GPS. In this case, the Export Options dialog will allow you to select a subset of the waypoints to export. For example, if the file contains 2500 numbers but the GPS can only hold 1000 at a time, you could create 3 upload exports. The first would be from 1 to 950, the second could be from 800 to 1750 and the third could be from 1550 to 2500. This gives some overlap and allows 50 open waypoints for new finds. If waypoint numbers are chosen for the GPS name, then the GPS names will correspond to the waypoint numbers in your list of 2500 and on your maps. Some GPSs like Lowrance allow you to name the export file and have many export files on the same SD memory card. That allows you to easily change the waypoint file while at sea. Others do not allow this option. So, you ask, how can I put these three files on the SD card if they are all named the same? The answer is to load three or more cards with one file each. Then label the cards as to their contents. These cards can be pretty small and therefore cheap as the files are small. Old camera cards will do. By the way, I have heard that certain Furunos only accept 128 MB cards.

For Furuno (or RayMarine) export, you can use the C-MAP export on those models using C-Map. This creates a file that the C-MAP PC Planner software can load onto a C-Map card for insertion into the GPS. If the model uses Navionics maps, these cards come in three flavors, so you have to have the card reader that accepts your card.

**Export to Raymarine via Raytech Navigator**

If you can't for some reason use the built-in Raymarine C/E-series exporter, (for example to retain your folder structure) then start with Andren LoranGPS. Once the file to be exported is loaded, go to Tools>Export File>Raymarine>RWF. This will first bring up a screen to name the resulting file. It is best if you save this file to the folder: C:\Program Files\Raymarine\Raymarine RayTech Navigator\Archive under the name "archive.rwf". Then you get the Export Options screen. Here, you select how many waypoints you want to export (assuming the file holds more than the Raymarine can hold). Once this is done, the file is exported to where the RayTech Navigator can get it. Open RayTech Navigator and start with the File menu. Choose Import/Export Routes and Waypoints. Then select Import from > Import from Raymarine Waypoint file. This should bring up the appropriate screen showing the file just created. Select and load that file. Now it is in RayTech Navigator and you can use its' Import/Export function again to save the file to the memory card as C/E-Series or whatever is appropriate.
**Warning.** Be very careful with Raytech Planner. All waypoints are imported into it as unlocked. What this means is that if you touch a waypoint on the plot screen with the mouse cursor, it will move to follow the mouse. This strange behavior was designed in and intended to allow sailors to easily move points around. However, for fisherman, this can be disaster. So, stay away from the waypoints with the mouse cursor. There are two ways to lock all the points while using this tool. First is to open each and every point and lock it. The second is to exit Raytech and find: C:\Program Files\Raymarine\Raymarine RayTech Navigator\marks.dat and open it. Then do a global search and replace of Locked=0 with Locked=1. You can do the same with Show=0 and Show=1 if you wish. Save the file and open Raytech and all points currently loaded will be locked.

**Export to Furuno**

For Furuno, see the import section for details. This export to GPS operation will replace all waypoints in the GPS with the new ones. This is the only way to delete more than one waypoint at a time. If for example, you wanted to delete all waypoints, you have two options. You can do a reset and lose all personalized setup information along with the waypoints, or load a file with just one waypoint and then delete it.

**Export to Garmin**

For Garmin/Mapsource exporting, assuming you don't want to use the direct upload/download capability, you would use the userdata.adm feature. *Initializing the card in the GPS is a necessary step for later exporting to the GPS. The GPS sets up the folder structure needed and also writes a file that identifies the GPS model and also the software model for the ADM file.* You export to the SD card into a folder called: Userdata which is a subfolder to the Garmin folder. This file is directly compatible with most Garmins that use the SD card for storage. If the GPS uses the proprietary Garmin card, then you will probably need to use the Mapsource program and its card reader to access the card. In that case export your file to a GDB, MPS, or GPX file. These files can be imported into Mapsource to be loaded into the GPS.

**Export to Lowrance/Eagle/Simrad**

For Lowrance/Eagle and some Simrads if you do not want to use the cable uploading capability, you can create USR files to write to an MMC/SD card. The card can hold many of these files for uploading at sea.

**Export to others**

For other formats, you can use the GPSBabel utility. This handles a large variety of GPS data formats and can convert any one to another. Of these, the GPX format is a good one to use to get the data into the program. A copy of GPSbabel is included with the program. GPS Babel is an open source software program free to anyone to use and is user supported. To use it, you select Tools>Export File>Other Formats. This brings up the GPSbabelGUI-2 screen. There is a zipped ReadMe file on the CD that has instructions if you need them. GPSBabel is not marine oriented, so it does not have all the translations you might need.

**Tag Waypoints**

Whenever you combine waypoints from several sources, you will want some way of differentiating which are which because some sources may have bad waypoints. If you are typing them in yourself, you can give them distinctive names. If however, you are combining an existing file from a friend, this routine will let you tag all the waypoints in that file with his initials before combining it with yours.
The tag is a 2 or 3 character group placed at the right end of the 32 character DESCRIPTION. An alternative is to COLOR ALL the friend’s waypoints.

**Swap/Fill Fields**

You may get a file of waypoints from a friend that is organized with the TD columns swapped or you may import a file where the Description and Comments are swapped. This command will reverse the TD1 and TD2 columns or the Description and Comments columns or the Depth and Rating columns in the file. If you import a file and the GPS short name ends up in the description field, you can copy that to the Name field. If you open a file made with a previous version of this program, the Name field will be linked to the Waypoint number. To change that use the FILL Name Field selection that brings up the following dialog.

![Fill the Name field](image)

The way linking works is that unless you enter a name in the Name field, it behaves just like the number column on the left side of the spreadsheet. The program handles this by having a blank name in the field. If you put in a name, thereafter the Name sticks to that waypoint. To return to a linked condition, erase the Name.

**Color All Waypoints**

If you get a file from someone else and want to distinguish it from yours on the graphical display, you can color all with this function. It sets the color of all waypoints in the file to one of the available colors. You type in the first letter to represent the color where upper case is dark and lower case is light. To remove colors from all waypoints, choose None as the color. This sets them to black. An alternative is to TAG WAYPOINTS.

**OTHER BOAT POSITION**

If you have a radar or other range and bearing finder aboard, you can determine the position of another boat from your position and the range and bearing to the other boat using this routine. This works for both Loran and GPS waypoints.
Harvest Sonar Log Files
Some Lowrance GPSs have a recording sonar that has the capability to log (save) all their sonar (depth recorder) data to a memory card. This creates a very large file on the card (for example 200 MB) containing all the sonar data for a whole day's trip. You can use the free Lowrance SonarViewer to replay all this sonar data. This gives you the ability to find all the places where you passed over a ledge or wreck and save that data to a Andren LoranGPS file. You might not have been watching the screen when going over something interesting, but it is captured nonetheless. On the date of this printing, SonarViewer version 1.2.2 allows you to play back and adjust the settings of any sonar log file recorded with the LCX-104C, LCX-110C, LCX-111C HD, LCX-15CI, LCX-16CI, LCX-17M, LCX-18C, LCX-19C, LCX-20C, LCX-25C, LCX-26C HD, LMS-240, LMS-320, LMS-320DF, LMS-330C, LMS-332C, LMS-335CDF, LMS-337C DF, LMS-480M, or LMS-480MDF. By pausing and hovering the cursor over the trace, you get a pop-up box with the Lat/Lon, depth, date, time, and sounding number. Without the harvester, you would have to write down this data and manually type it into the program. However, the SonarViewer can output chart information to a text file in a comma-delimited form. This data is not the sonar trace itself, but the data in the pop-up window for every sounding. There are typically around 100,000 soundings in an 8-hour log. The Sonar Log Harvester can read this file and create a waypoint when given only the sounding number. It notes the GPS speed and calculates the ledge height while it is doing the capture. For this operation is useful to have a large computer screen or two monitors so you can more easily go between the Andren and Sonar Viewer programs.

7. Plan Trip Menu
This menu selection is for planning a trip by selecting waypoints from the file. This trip plan will show range and bearing from one waypoint to the next. A trip plan is like a route in your GPS in that it consists of an ordered sequence of waypoints from your list. Unlike a Route, this plan can be saved and then it is divorced from the file it was created from. In a GPS, a route becomes corrupt if one of the waypoints in the route is deleted.

New Trip
This command resets the trip counter to zero and splits the screen into two spreadsheets. The upper sheet contains the waypoints in your file. The lower sheet is the trip plan and shows the waypoints constituting the trip.

You can add waypoints to the trip in one of two ways. One way is to click on a waypoint on the upper sheet and it will be repeated on the lower sheet as the next trip point. The other way is to type the
waypoint number in the **Number** column of the trip sheet below the last trip point. Once you hit enter, the waypoint is copied to the trip sheet. The range and bearing columns on the trip sheet will display R/B from one point to the next, so the starting point’s R&B are always zero.

To delete a waypoint from the trip sheet, click on its number in the left column as you would to delete a waypoint normally. There is no insert capability, so if you mess up, back up and redo.

---

**Continue Trip**

If you planned a trip and then quit, the trip is still in memory unless you made any changes the file it was based on or loaded another file. This command will let you resume trip planning where you left off.

**Save Trip**

After a trip is planned, you can save it as a file on the disk to refer to later. This file will afterwards will lose its trip characteristics and behave as a regular data file. That is, instead of being a sequence of waypoint numbers is becomes a sequence of waypoints. You cannot import it back as a trip.

**Print Trip**

If you want to print the trip, this command will print it with the present printing settings, but the range and bearing will be from one point to the next rather than all points to one point as in the regular printout. Be sure that R/B is one of the printing selections if you want it on the printout. The printed plan will also have the total mileage.
Quit Trip Plan
This command returns you to the normal display modes and turns off the trip mode. Your trip is saved in memory unless you change the file it is based on. A trip plan is like a route and it consists of an ordered sequence of waypoint numbers. Changing the underlying waypoint numbers corrupts the trip so it is cancelled.

8. HELP MENU  Hot Key F1

Contents
On line help is available with this selection or Hot Key F1. If you are working with some sub window or menu item, push F1 to get help on that subject. Once in the help system, you can navigate to any subject easily. The help file may contain information that is newer than the manual since it is often updated when the program is improved.

About
Displays information on the version of the program that you are using as well as the contact address for Andren Software Co.

View the Readme File
Opens the ReadMe file in Windows Notepad. It contains information that could be useful.

Read/Print Manual
Opens this manual file in Adobe Acrobat reader and lets you read or print it. Hopefully you have Adobe Reader installed. If not, then you need to install it.

Check for Updates
This opens a copy of Internet Explorer pointed to the Andren Software site's Updates page so you can see if a newer update is available and if so, allows you to download it. Remember, free updates are available for a period of 2 years or so and after that, you must pay for an upgrade. The update is a zipped file with a few files that may have changed over the last 2 years. An upgrade is a whole new installation package that insures that you have all the files needed.
The LoranGPS program VI. Menu Reference • 91

INDEX
abandoning ........................................................................................................37
accuracy ............................................................................................................64
add readings .....................................................................................................33
alert message ...................................................................................................36
algorithms .........................................................................................................22
ascending .........................................................................................................29
ASF correction factors .....................................................................................17
ASFs ..................................................................................................................64
assistance .........................................................................................................6
B&W .................................................................................................................50
backspacing .....................................................................................................40
backup ...............................................................................................................27
bearing .............................................................................................................39, 40
bold font ..........................................................................................................31
borders ..............................................................................................................29
calibrate conversions .......................................................................................14
calibration ........................................................................................................11, 17, 36, 66
center .................................................................................................................8
center the chart ................................................................................................50
centering the chart ..........................................................................................50
chain designations .............................................................................................62
chain selection ...................................................................................................59
chains ..................................................................................................................9
challenged ...........................................................................................................36
change chain .....................................................................................................36
chart ...................................................................................................................41
CHART CENTER ................................................................................................42
chart operations ................................................................................................50
charting options .................................................................................................41
choose colors .....................................................................................................50
Color ..................................................................................................................37
color all ..............................................................................................................86
com port .............................................................................................................53
combine .............................................................................................................6, 28
comments .........................................................................................................30, 37
connectors ...........................................................................................................54
conversion ..........................................................................................................5
conversion methods ............................................................................................63
convert ...............................................................................................................13, 66
correct file .........................................................................................................36
create map ..........................................................................................................46
custom chains ....................................................................................................61
datecode .............................................................................................................37
dBase .................................................................................................................22
Defense Mapping Agency ..................................................................................64
delete file ..........................................................................................................28
delete readings ...................................................................................................37
description ..........................................................................................................37
display ...............................................................................................................39
DMA ....................................................................................................................17
DOS .....................................................................................................................7
download .............................................................................................................5
duplicate ............................................................................................................5, 6, 39
duplicates ..........................................................................................................58
Eagle/Lowrance .................................................................................................67
edit .......................................................................................................................33
editing ...............................................................................................................11
exact duplicates ...............................................................................................39
Excel ....................................................................................................................39
expand ...............................................................................................................51
export ...............................................................................................................5, 83
favorite chain ....................................................................................................9
features .............................................................................................................52
files of type .......................................................................................................26
find .....................................................................................................................38
find next ..........................................................................................................38
FOLLOW BOAT ...............................................................................................54
Fugawi ...............................................................................................................76
function keys ....................................................................................................37
Furuno ...............................................................................................................76
Garmin ...............................................................................................................70
government tables ............................................................................................63, 65
grid lines ..........................................................................................................31
HARVEST .........................................................................................................87
header .................................................................................................................8
help .....................................................................................................................89
identify reading ................................................................................................51
import ...............................................................................................................5, 10, 72
initializing ...........................................................................................................8
inlet .....................................................................................................................8
learn ....................................................................................................................10
line spacing .....................................................................................................31
Loran A .........................................................................................................62
Loran C .........................................................................................................61
Loran Locator ....................................................................................................81
loran stations ......................................................................................................36
loran to GPS ......................................................................................................13
LoranGPS ..........................................................................................................7
Magellan ...........................................................................................................70
MagVar ............................................................................................................25
map ...................................................................................................................46
maps ...................................................................................................................5
Maptech ..........................................................................................................81
master/slave ....................................................................................................61
menu ...................................................................................................................16
Mercator .............................................................................................................21
merge ...................................................................................................................25
modify map ...........................................................................................................46
Nav Pro ..............................................................................................................81
NMEA 183 .......................................................................................................53, 81
number formats ...............................................................................................45
number formatting ...........................................................................................12
open ...................................................................................................................25
organizing ..........................................................................................................5, 6
other boat ..........................................................................................................86
plan .....................................................................................................................6
plot .....................................................................................................................6